net-ftp/filezilla: Replace C++14 check with simpler test-flag-CXX
authorMike Gilbert <floppym@gentoo.org>
Wed, 19 Aug 2015 16:41:44 +0000 (12:41 -0400)
committerMike Gilbert <floppym@gentoo.org>
Thu, 20 Aug 2015 14:36:11 +0000 (10:36 -0400)
Package-Manager: portage-2.2.20_p134

net-ftp/filezilla/filezilla-3.13.0.ebuild

index 3f0e7a090ea636d2006fbd371f9f0f8500f7e1b9..2678ed5a89df911ffe260fa0a9c6bb80da204a40 100644 (file)
@@ -37,16 +37,13 @@ DEPEND="${RDEPEND}
 S="${WORKDIR}"/${PN}-${MY_PV}
 
 pkg_pretend() {
-if [[ ${MERGE_TYPE} != binary ]]; then
-               echo 'int main() {return 0;}' > "${T}"/test.cxx || die
-               ebegin "Trying to build a C++14 test program"
-               if ! $(tc-getCXX) -std=c++14 -o /dev/null "${T}"/test.cxx; then
+       if [[ ${MERGE_TYPE} != binary ]]; then
+               if ! test-flag-CXX -std=c++14; then
                        eerror "${P} requires C++14-capable C++ compiler. Your current compiler"
                        eerror "does not seem to support -std=c++14 option. Please upgrade your compiler"
                        eerror "to gcc-4.9 or an equivalent version supporting C++14."
                        die "Currently active compiler does not support -std=c++14"
                fi
-               eend ${?}
        fi
 }