app-misc/glimpse: new EAPI=6 revision with ISC license.
authorMichael Orlitzky <mjo@gentoo.org>
Sun, 7 May 2017 00:23:11 +0000 (20:23 -0400)
committerMichael Orlitzky <mjo@gentoo.org>
Sun, 7 May 2017 00:23:26 +0000 (20:23 -0400)
Gentoo-Bug: 614676

Package-Manager: Portage-2.3.3, Repoman-2.3.1

app-misc/glimpse/files/glimpse-4.18.6-makefile.patch [new file with mode: 0644]
app-misc/glimpse/glimpse-4.18.6-r1.ebuild [moved from app-misc/glimpse/glimpse-4.18.6.ebuild with 78% similarity]

diff --git a/app-misc/glimpse/files/glimpse-4.18.6-makefile.patch b/app-misc/glimpse/files/glimpse-4.18.6-makefile.patch
new file mode 100644 (file)
index 0000000..a6f3b43
--- /dev/null
@@ -0,0 +1,42 @@
+--- a/Makefile.in      2006-03-10 20:42:12.000000000 -0500
++++ b/Makefile.in.new  2010-08-12 21:12:41.000000000 -0400
+@@ -52,7 +52,7 @@
+ PROGAGREP     = agrep/agrep
+ OPTIMIZEFLAGS   = -O2
+ INCLUDEFLAGS    = -I$(INDEXDIR) -I$(AGREPDIR) -I$(TEMPLATEDIR)/include
+-CFLAGS          = $(INCLUDEFLAGS) $(DEFS)
++CFLAGS          = $(INCLUDEFLAGS) $(DEFS) $(OPTIMIZEFLAGS)
+ OBJS          = get_filename.o \
+               get_index.o \
+@@ -78,7 +78,7 @@
+               $(INDEXDIR)/memlook.c \
+               $(INDEXDIR)/io.c
+-all:  build-sub @TARGET@
++all:  build-sub
+ Sall:         $(PROG) $(PROGSERVER) $(PROGINDEX) 
+ agrep:                $(PROGAGREP)
+ NOTSall:      $(NOTSPROG) $(NOTSPROGSERVER)
+@@ -87,6 +87,7 @@
+       for d in $(SUBDIRS) ; do \
+               ( cd $$d; $(MAKE) ); \
+       done
++      $(MAKE) @TARGET@
+ # Check target
+@@ -105,11 +106,11 @@
+ install-man:
+       for d in $(MANUAL) ; do \
+-              $(INSTALL_MAN) $$d $(mandir) ; \
++              $(INSTALL_MAN) $$d $(mandir)/man1/ ; \
+       done
+ installdirs:  mkinstalldirs
+-      $(srcdir)/mkinstalldirs $(bindir) $(mandir)
++      $(srcdir)/mkinstalldirs $(bindir) $(mandir)/man1/
+ clean:
+       for d in $(SUBDIRS); do \
similarity index 78%
rename from app-misc/glimpse/glimpse-4.18.6.ebuild
rename to app-misc/glimpse/glimpse-4.18.6-r1.ebuild
index 240fc0ca51de20bba5df80146ccd69b8da8657d0..d4069ba809c73318748f3ca007f2b2bf577f46f2 100644 (file)
@@ -1,15 +1,15 @@
 # Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI=6
 
-inherit flag-o-matic eutils
+inherit flag-o-matic
 
 DESCRIPTION="A index/query system to search a large set of files quickly"
 HOMEPAGE="http://webglimpse.net/"
 SRC_URI="http://webglimpse.net/trial/${P}.tar.gz"
 
-LICENSE="glimpse"
+LICENSE="ISC"
 SLOT="0"
 KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
 IUSE="static"
@@ -17,6 +17,8 @@ IUSE="static"
 RDEPEND="!dev-libs/tre
        !app-text/agrep"
 
+PATCHES=( "${FILESDIR}/${PN}-4.18.6-makefile.patch" )
+
 src_prepare() {
        sed -i \
                -e "s:CC=.*:CC=$(tc-getCC):" \
@@ -38,19 +40,20 @@ src_prepare() {
                {agrep,compress,index}/Makefile.in \
                || die "LDFLAGS sed failed"
 
-       epatch "${FILESDIR}"/${PN}-4.18.5-makefile.patch
+       default
 }
 
 src_configure() {
        use static && append-ldflags -static
-
-       econf || die
+       default
 }
 
 src_compile() {
-       emake OPTIMIZEFLAGS="${CFLAGS}" || die
+       # The OPTIMIZEFLAGS variable is our own, patched in...
+       emake OPTIMIZEFLAGS="${CFLAGS}"
 }
 
 src_install() {
-       einstall || die
+       # The build system is buggy; we get sandbox violations without this.
+       emake prefix="${ED}/usr" install
 }