Use -mt prefix for the boost libs, thanks to Peter Koeleman <peter@peerweb.nl> for...
authorRaúl Porcel <armin76@gentoo.org>
Wed, 14 Mar 2007 17:07:24 +0000 (17:07 +0000)
committerRaúl Porcel <armin76@gentoo.org>
Wed, 14 Mar 2007 17:07:24 +0000 (17:07 +0000)
Package-Manager: portage-2.1.2.2

net-libs/rb_libtorrent/ChangeLog
net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild

index d7398050a9afe32942e974e71c9cfda1ded26b58..65e52ff90056c5d7d3857aa74fbba5462553104c 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for net-libs/rb_libtorrent
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.4 2007/02/14 15:33:01 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.5 2007/03/14 17:07:24 armin76 Exp $
+
+  14 Mar 2007; Raúl Porcel <armin76@gentoo.org> rb_libtorrent-0.11.ebuild:
+  Use -mt prefix for the boost libs, thanks to Peter Koeleman
+  <peter@peerweb.nl> for reporting, bug 170887
 
   14 Feb 2007; Raúl Porcel <armin76@gentoo.org> rb_libtorrent-0.11.ebuild:
   Fix built_with_use, thanks to Constantine D. Kardaris <ckardaris at gmail
index e665a5f59b11baf243133e006454b66f30b13e78..1c5430798ab69317a9ada272ce5eeb8e0d982828 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild,v 1.3 2007/02/14 15:31:46 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild,v 1.4 2007/03/14 17:07:24 armin76 Exp $
 
 WANT_AUTOCONF="latest"
 WANT_AUTOMAKE="latest"
@@ -32,7 +32,13 @@ pkg_setup() {
 }
 
 src_compile() {
-       econf $(use_enable debug) || die "econf failed"
+       BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+                       --with-boost-filesystem=boost_filesystem-mt \
+                       --with-boost-thread=boost_thread-mt \
+                       --with-boost-regex=boost_regex-mt \
+                       --with-boost-program_options=boost_program_options-mt"
+
+       econf $(use_enable debug) ${BOOST_LIBS} || die "econf failed"
        emake || die "emake failed"
 }