lxqt-base/lxqt-panel: add version 0.15.1
authorJimi Huotari <chiitoo@gentoo.org>
Mon, 27 Apr 2020 18:58:57 +0000 (21:58 +0300)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 20 May 2020 23:28:31 +0000 (01:28 +0200)
USE="sensors" renamed to make use of the global 'lm-sensors' flag.

Closes: https://bugs.gentoo.org/720716
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jimi Huotari <chiitoo@gentoo.org>
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
lxqt-base/lxqt-panel/Manifest
lxqt-base/lxqt-panel/lxqt-panel-0.15.1.ebuild [new file with mode: 0644]

index 0fd084b44adb689e7e23f55abe5c35e57918b5f1..f1f45c0d7c13b5b3e1ac31e390ff8e684d276500 100644 (file)
@@ -1 +1,2 @@
 DIST lxqt-panel-0.14.1.tar.xz 439252 BLAKE2B 28172f61cba99450965ca2c1660ca51f268a93ffc32769b270e5c5984b8f3534c3e8736f07334bdec1a1eb408ef35a20bf12de5a445faff161a93efbdacbe51c SHA512 e7cb361a13ac480cda50bc0549d5501f0d4f5bb6c8e257febf81550aaa88c0c55b615762aedb1f03fd654f79efe5aa2590b1dd592f6ae8c7e5a8d08086e0a687
+DIST lxqt-panel-0.15.1.tar.xz 473356 BLAKE2B 297e704c51b3c950551fd09012c0aa533fdecf3d46d0f988428ce4100b7936970c5b400c6dc77103e26c07a05d10611fcd921354063cc55252b0a9cb93b0ebe6 SHA512 8eb9856faa2ce56c56df7514772d3ae6d31339a10d16e1ed659be0a2affc57fd16e01e05cb67c4205dfb773234ca9b8a69f414f742ccc30495bf4e2acfa0513f
diff --git a/lxqt-base/lxqt-panel/lxqt-panel-0.15.1.ebuild b/lxqt-base/lxqt-panel/lxqt-panel-0.15.1.ebuild
new file mode 100644 (file)
index 0000000..7e0b20d
--- /dev/null
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="LXQt desktop panel and plugins"
+HOMEPAGE="https://lxqt.github.io/"
+
+MY_PV="$(ver_cut 1-2)*"
+
+if [[ ${PV} = *9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+       SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="LGPL-2.1 LGPL-2.1+"
+SLOT="0"
+IUSE="+alsa colorpicker cpuload +desktopswitch +directorymenu dom +kbindicator
++mainmenu +mount networkmonitor pulseaudio +quicklaunch lm-sensors +showdesktop
++spacer statusnotifier sysstat +taskbar +tray +volume +worldclock"
+
+# Work around a missing header issue: https://bugs.gentoo.org/666278
+REQUIRED_USE="
+       || ( desktopswitch mainmenu showdesktop taskbar )
+       volume? ( || ( alsa pulseaudio ) )
+"
+
+BDEPEND="
+       dev-qt/linguist-tools:5
+       >=dev-util/lxqt-build-tools-0.7.0
+       virtual/pkgconfig
+"
+DEPEND="
+       >=dev-libs/libqtxdg-3.3.1
+       dev-qt/qtcore:5
+       dev-qt/qtdbus:5
+       dev-qt/qtgui:5
+       dev-qt/qtsvg:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       dev-qt/qtxml:5
+       kde-frameworks/kwindowsystem:5[X]
+       >=lxde-base/lxmenu-data-0.1.5
+       >=lxde-base/menu-cache-1.1.0
+       =lxqt-base/liblxqt-${MY_PV}
+       =lxqt-base/lxqt-globalkeys-${MY_PV}
+       x11-libs/libX11
+       cpuload? ( sys-libs/libstatgrab )
+       kbindicator? ( x11-libs/libxkbcommon )
+       lm-sensors? ( sys-apps/lm-sensors )
+       mount? ( kde-frameworks/solid:5 )
+       networkmonitor? ( sys-libs/libstatgrab )
+       statusnotifier? ( dev-libs/libdbusmenu-qt[qt5(+)] )
+       sysstat? ( >=lxqt-base/libsysstat-0.4.1 )
+       tray? (
+               x11-libs/libxcb:=
+               x11-libs/libXcomposite
+               x11-libs/libXdamage
+               x11-libs/libXrender
+               x11-libs/xcb-util
+       )
+       volume? (
+               alsa? ( media-libs/alsa-lib )
+               pulseaudio? (
+                       media-sound/pavucontrol-qt
+                       media-sound/pulseaudio
+               )
+       )
+"
+RDEPEND="${DEPEND}
+       !lxqt-base/lxqt-l10n
+"
+
+src_configure() {
+       local mycmakeargs=(
+               # Plugins
+               -DCOLORPICKER_PLUGIN=$(usex colorpicker)
+               -DCPULOAD_PLUGIN=$(usex cpuload)
+               -DDESKTOPSWITCH_PLUGIN=$(usex desktopswitch)
+               -DDIRECTORYMENU_PLUGIN=$(usex directorymenu)
+               -DDOM_PLUGIN=$(usex dom)
+               -DKBINDICATOR_PLUGIN=$(usex kbindicator)
+               -DMAINMENU_PLUGIN=$(usex mainmenu)
+               -DMOUNT_PLUGIN=$(usex mount)
+               -DNETWORKMONITOR_PLUGIN=$(usex networkmonitor)
+               -DQUICKLAUNCH_PLUGIN=$(usex quicklaunch)
+               -DSENSORS_PLUGIN=$(usex lm-sensors)
+               -DSHOWDESKTOP_PLUGIN=$(usex showdesktop)
+               -DSPACER_PLUGIN=$(usex spacer)
+               -DSTATUSNOTIFIER_PLUGIN=$(usex statusnotifier)
+               -DSYSSTAT_PLUGIN=$(usex sysstat)
+               -DTASKBAR_PLUGIN=$(usex taskbar)
+               -DTRAY_PLUGIN=$(usex tray)
+               -DVOLUME_PLUGIN=$(usex volume)
+               -DWORLDCLOCK_PLUGIN=$(usex worldclock)
+       )
+
+       if use volume; then
+               mycmakeargs+=(
+                       -DVOLUME_USE_ALSA=$(usex alsa)
+                       -DVOLUME_USE_PULSEAUDIO=$(usex pulseaudio)
+               )
+       fi
+
+       cmake_src_configure
+}
+
+src_install() {
+       cmake_src_install
+       doman panel/man/*.1
+}