revbump as init script changed, cleanin out old
authorRobert Buchholz <rbu@gentoo.org>
Sun, 7 Jan 2007 03:09:00 +0000 (03:09 +0000)
committerRobert Buchholz <rbu@gentoo.org>
Sun, 7 Jan 2007 03:09:00 +0000 (03:09 +0000)
Package-Manager: portage-2.1.1-r2

app-misc/g15daemon/ChangeLog
app-misc/g15daemon/files/digest-g15daemon-1.2.6a-r1 [new file with mode: 0644]
app-misc/g15daemon/files/g15daemon-1.2.6a.confd [new file with mode: 0644]
app-misc/g15daemon/files/g15daemon-1.2.6a.initd [new file with mode: 0644]
app-misc/g15daemon/g15daemon-1.2.5.ebuild
app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild [new file with mode: 0644]

index cf7572241434f74d4a218b10aeff42d6940303ee..4115cd061112ec9a56cecc7e96ade6a56c34e864 100644 (file)
@@ -1,6 +1,15 @@
 # ChangeLog for app-misc/g15daemon
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.7 2006/12/06 11:37:23 jokey Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/ChangeLog,v 1.8 2007/01/07 03:09:00 rbu Exp $
+
+*g15daemon-1.2.6a-r1 (07 Jan 2007)
+
+  07 Jan 2007; Robert Buchholz <rbu@gentoo.org>
+  -files/g15daemon-1.2.3.initd, +files/g15daemon-1.2.6a.confd,
+  +files/g15daemon-1.2.6a.initd, -g15daemon-1.2.3.ebuild,
+  g15daemon-1.2.5.ebuild, -g15daemon-1.2.6a.ebuild,
+  +g15daemon-1.2.6a-r1.ebuild:
+  revbump as init script changed, cleanin out old
 
 *g15daemon-1.2.6a (06 Dec 2006)
 
diff --git a/app-misc/g15daemon/files/digest-g15daemon-1.2.6a-r1 b/app-misc/g15daemon/files/digest-g15daemon-1.2.6a-r1
new file mode 100644 (file)
index 0000000..d5d09ba
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ba220f1fda33283af307c109cc520f61 g15daemon-1.2.6a.tar.bz2 273767
+RMD160 947441a1c89d1f45f02094a59735f488a76ce285 g15daemon-1.2.6a.tar.bz2 273767
+SHA256 583c4bece816b712959aba51f49d78bb587e215fbb6a322efe832477c74f2564 g15daemon-1.2.6a.tar.bz2 273767
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.6a.confd b/app-misc/g15daemon/files/g15daemon-1.2.6a.confd
new file mode 100644 (file)
index 0000000..c190c17
--- /dev/null
@@ -0,0 +1,5 @@
+# /etc/conf.d/g15daemon: Configuration for the g15daemon
+
+# Key to switch the client-screens. Default is the MR key,
+# Set to "yes" to use L1 key instead (black round key below the LCD, above the multimedia keys).
+CLIENT_SWITCH_L1="no"
\ No newline at end of file
diff --git a/app-misc/g15daemon/files/g15daemon-1.2.6a.initd b/app-misc/g15daemon/files/g15daemon-1.2.6a.initd
new file mode 100644 (file)
index 0000000..499fcd5
--- /dev/null
@@ -0,0 +1,36 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/files/g15daemon-1.2.6a.initd,v 1.1 2007/01/07 03:09:00 rbu Exp $
+
+# Init script for g15daemon
+
+depend() {
+       after hotplug
+       after usb
+       after modules
+}
+
+start() {
+       ebegin "Starting g15daemon"
+
+       # Does the input device already exist?
+       if [[ -e /proc/modules && ! -e /dev/input/uinput ]] ; then
+               # We can load modules, but uinput device does not exist
+               einfo "Loading uinput module"
+               /sbin/modprobe uinput &> /dev/null
+       fi
+
+       local SWITCHKEY=""
+       [[ ${CLIENT_SWITCH_L1} = "yes" ]] && SWITCHKEY="--switch"
+       start-stop-daemon --start --background --pidfile /var/run/g15daemon.pid \
+               --exec /usr/sbin/g15daemon -- ${SWITCHKEY}
+       eend $? "Failed to start g15daemon."
+}
+
+stop() {
+       ebegin "Stopping g15daemon"
+       /usr/sbin/g15daemon -k 2&> /dev/null  \
+               || start-stop-daemon --stop --quiet --pidfile /var/run/g15daemon.pid
+       eend $?
+}
index 308c42d1482e7e527eb2d541738760a8d0fb210c..d8c58d19a0b5139835c8e4b33a23b80d0350e833 100644 (file)
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.5.ebuild,v 1.1 2006/11/13 23:18:01 jokey Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.5.ebuild,v 1.2 2007/01/07 03:09:00 rbu Exp $
 
 inherit eutils linux-info perl-module python multilib
 
@@ -83,13 +83,13 @@ src_install() {
        newinitd "${FILESDIR}/${P}.initd" ${PN}
 
        if use perl; then
-               einfo "Installing Perl Bindings (G15Daemon.pm)"
+               ebegin "Installing Perl Bindings (G15Daemon.pm)"
                cd "${WORKDIR}/G15Daemon-0.2"
                perl-module_src_install
        fi
 
        if use python; then
-               einfo "Installing Python Bindings (g15daemon.py)"
+               ebegin "Installing Python Bindings (g15daemon.py)"
                cd "${WORKDIR}/pyg15daemon"
                python_version
 
@@ -102,29 +102,28 @@ src_install() {
 pkg_postinst() {
        if use python; then
                python_mod_optimize "${ROOT}/usr/lib/python*/site-packages/g15daemon"
-               einfo ""
+               echo ""
        fi
 
-       einfo "To use g15daemon, you need to add g15daemon to the default runlevel."
-       einfo "This can be done with:"
-       einfo "# /sbin/rc-update add g15daemon default"
-       einfo ""
-       einfo "To have all new keys working in X11,"
-       einfo "you'll need create a specific xmodmap in your home directory"
-       einfo "or edit the existant one."
-       einfo ""
-       einfo "create the xmodmap:"
-       einfo "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
-       einfo ""
-       einfo "adding keycodes to an existing xmodmap:"
-       einfo "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
-       einfo ""
-       einfo "NOTE: the daemon now supports to use the small round key"
-       einfo "instead of MR for switching LCD clients. see /etc/conf.d"
+       elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+       elog "This can be done with:"
+       elog "# /sbin/rc-update add g15daemon default"
+       elog ""
+       elog "To have all new keys working in X11, you'll need create a "
+       elog "specific xmodmap in your home directory or edit the existent one."
+       elog ""
+       elog "Create the xmodmap:"
+       elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+       elog ""
+       elog "Adding keycodes to an existing xmodmap:"
+       elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+       elog ""
+       elog "Note: the daemon now supports to use the small round key"
+       elog "instead of MR for switching LCD clients. see /etc/conf.d/g15daemon"
 }
 
 pkg_postrm() {
        if use python; then
                python_mod_cleanup "${ROOT}/usr/lib/python*/site-packages/g15daemon"
        fi
-}
\ No newline at end of file
+}
diff --git a/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild b/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild
new file mode 100644 (file)
index 0000000..4f11105
--- /dev/null
@@ -0,0 +1,129 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-misc/g15daemon/g15daemon-1.2.6a-r1.ebuild,v 1.1 2007/01/07 03:09:00 rbu Exp $
+
+inherit eutils linux-info perl-module python multilib
+
+DESCRIPTION="G15daemon takes control of the G15 keyboard, through the linux kernel uinput device driver"
+HOMEPAGE="http://g15daemon.sourceforge.net/"
+SRC_URI="mirror://sourceforge/g15daemon/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="perl python"
+
+DEPEND="dev-libs/libusb
+       dev-libs/libdaemon
+       >=dev-libs/libg15-1.1.0
+       perl? ( >=dev-perl/Inline-0.4 )
+       python? ( dev-lang/python )"
+
+RDEPEND="${DEPEND}
+       perl? ( dev-perl/GDGraph )"
+
+uinput_check() {
+       ebegin "Checking for uinput support"
+       linux_chkconfig_present INPUT_UINPUT
+       eend $?
+
+       if [[ $? -ne 0 ]] ; then
+               eerror "To use g15daemon, you need to compile your kernel with uinput support."
+               eerror "Please enable uinput support in your kernel config, found at:"
+               eerror
+               eerror "Device Drivers -> Input Device ... -> Miscellaneous devices -> User level driver support."
+               eerror
+               eerror "Once enabled, you should have the /dev/input/uinput device."
+               eerror "g15daemon will not work without the uinput device."
+               die "INPUT_UINPUT support not detected!"
+       fi
+}
+
+pkg_setup() {
+       linux-info_pkg_setup
+       uinput_check
+}
+
+src_unpack() {
+       unpack ${A}
+       if use perl; then
+               unpack "./${P}/lang-bindings/perl-G15Daemon-0.2.tar.gz"
+       fi
+       if use python; then
+               unpack "./${P}/lang-bindings/pyg15daemon-0.0.tar.bz2"
+       fi
+}
+
+src_compile() {
+       econf || die "configure failed"
+
+       emake || die "make failed"
+
+       if use perl; then
+               cd "${WORKDIR}/G15Daemon-0.2"
+               perl-module_src_compile
+       fi
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+
+       # remove odd docs installed my make
+       rm "${D}/usr/share/doc/${P}/"{LICENSE,README.usage}
+       gzip "${D}/usr/share/doc/${P}/"*
+
+       insinto /usr/share/g15daemon/contrib
+       doins contrib/xmodmaprc
+       doins contrib/xmodmap.sh
+       if use perl; then
+               doins contrib/testbindings.pl
+       fi
+
+       newconfd "${FILESDIR}/${P}.confd" g15daemon
+       newinitd "${FILESDIR}/${P}.initd" g15daemon
+
+       if use perl; then
+               ebegin "Installing Perl Bindings (G15Daemon.pm)"
+               cd "${WORKDIR}/G15Daemon-0.2"
+               perl-module_src_install
+       fi
+
+       if use python; then
+               ebegin "Installing Python Bindings (g15daemon.py)"
+               cd "${WORKDIR}/pyg15daemon"
+               python_version
+
+               insinto /usr/$(get_libdir)/python${PYVER}/site-packages/g15daemon
+               doins g15daemon.py
+               newdoc AUTHORS pyg15daemon_AUTHORS
+       fi
+}
+
+pkg_postinst() {
+       if use python; then
+               python_mod_optimize "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+               echo ""
+       fi
+
+       elog "To use g15daemon, you need to add g15daemon to the default runlevel."
+       elog "This can be done with:"
+       elog "# /sbin/rc-update add g15daemon default"
+       elog ""
+       elog "To have all new keys working in X11, you'll need create a "
+       elog "specific xmodmap in your home directory or edit the existent one."
+       elog ""
+       elog "Create the xmodmap:"
+       elog "cp /usr/share/g15daemon/contrib/xmodmaprc ~/.Xmodmap"
+       elog ""
+       elog "Adding keycodes to an existing xmodmap:"
+       elog "cat /usr/share/g15daemon/contrib/xmodmaprc >> ~/.Xmodmap"
+       elog ""
+       elog "Note: the daemon now supports to use the small round key"
+       elog "instead of MR for switching LCD clients. see /etc/conf.d/g15daemon"
+}
+
+pkg_postrm() {
+       if use python; then
+               python_mod_cleanup "${ROOT}/usr/lib/python*/site-packages/g15daemon"
+       fi
+}