dev-vcs/cvs-fast-export: bump up to 1.45
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 22 Jan 2019 23:13:24 +0000 (23:13 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 22 Jan 2019 23:21:16 +0000 (23:21 +0000)
Package-Manager: Portage-2.3.57, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-vcs/cvs-fast-export/Manifest
dev-vcs/cvs-fast-export/cvs-fast-export-1.45.ebuild [new file with mode: 0644]

index 9a6083430bf50101ba757effcefe7afb34b95647..aed89cb081b023219377eb3a75aa1e41356babb9 100644 (file)
@@ -1,2 +1,3 @@
 DIST cvs-fast-export-1.38.tar.gz 396524 BLAKE2B 41e7d5210671aae9063d3fa1da8a61ff581cdbe6745573d158576e495aeba0958d1cf20c9d8435e0c12747428b884eeab3b2d926a93d580589f17db8102ad27e SHA512 ed2aabc417b093c1742ea15bd21855c600a46a5ab72758d15bab24672b6e648531416a6b28c17e6faedd67b4c697b004ba3316cd65cb0ec638566c26878e9428
 DIST cvs-fast-export-1.44.tar.gz 512435 BLAKE2B 2dfcd34efbf400c9d9a726933a18504a8d241928646d73f54f1860d1580030fa0328df4aaf5b57f1fbdc4b7b2c0a988ac903c8f9f03384515fdd5241fbf51c06 SHA512 66209589c692d2b0b2e60494386cb4dbae04f5f6676c89733d3ad6e5ce8b76d3cb70d7b03430be643e44eaff5848fdb7413795e10716a9ed8b4f2a4043f822a5
+DIST cvs-fast-export-1.45.tar.gz 517917 BLAKE2B 47d0debe2ea4d5674630065ee320c5db71f7ab6e4b17b7850d28c1951359ea98c639639574a7c3a25b9ec4e09ff53f1c5db566bff070e6381061fd828e875061 SHA512 f3acadabdd74f2099003a0cda29b021ea2173127af1a358bcb855397be95edaff2b1f30d3cf31dd6c08e79a8bad07b80b826c374d9b5e43555ec60d08dd577e4
diff --git a/dev-vcs/cvs-fast-export/cvs-fast-export-1.45.ebuild b/dev-vcs/cvs-fast-export/cvs-fast-export-1.45.ebuild
new file mode 100644 (file)
index 0000000..c1ecf98
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="fast-export history from a CVS repository or RCS collection"
+HOMEPAGE="http://www.catb.org/~esr/cvs-fast-export/"
+SRC_URI="http://www.catb.org/~esr/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+       app-text/asciidoc"
+
+RESTRICT=test # upstream does not ship some tests in tarball
+
+src_prepare() {
+       default
+
+       tc-export CC
+       export prefix=/usr
+
+       # respect CC, CFLAGS and LDFLAGS
+       sed \
+               -e 's/cc /$(CC) $(LDFLAGS) /' \
+               -e 's/^CFLAGS += -O/#&/' \
+               -e 's/CFLAGS=/CFLAGS+=/' \
+               -i Makefile || die
+}
+
+src_compile() {
+       # '.adoc.html' rules can't be executed in parallel
+       # as they reuse the same 'docbook-xsl.css' file name.
+       emake -j1 html
+       # Allow full parallelism for the rest
+       emake
+}
+
+src_install() {
+       default
+       dodoc README
+}