www-apps/cgit: Rename IUSE=jit to IUSE=luajit
authorMatt Turner <mattst88@gentoo.org>
Mon, 23 Mar 2020 22:14:47 +0000 (15:14 -0700)
committerMatt Turner <mattst88@gentoo.org>
Mon, 23 Mar 2020 22:19:04 +0000 (15:19 -0700)
Closes: https://bugs.gentoo.org/653306
Signed-off-by: Matt Turner <mattst88@gentoo.org>
www-apps/cgit/cgit-1.2.3.ebuild
www-apps/cgit/cgit-9999.ebuild

index 7cc6e5b77e70c573aaa55a65d7033334e23a0817..36c2fa840d52a8331125fe8ed52f83a5e6529e8d 100644 (file)
@@ -19,7 +19,7 @@ SRC_URI="https://www.kernel.org/pub/software/scm/git/git-${GIT_V}.tar.xz
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc +highlight libressl +lua +jit"
+IUSE="doc +highlight libressl +lua +luajit"
 
 RDEPEND="
        dev-vcs/git
@@ -28,7 +28,10 @@ RDEPEND="
        highlight? ( || ( dev-python/pygments app-text/highlight ) )
        !libressl? ( dev-libs/openssl:0= )
        libressl? ( dev-libs/libressl:0= )
-       lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua:0 ) )
+       lua? (
+               luajit? ( dev-lang/luajit )
+               !luajit? ( dev-lang/lua:0 )
+       )
 "
 # ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
 DEPEND="${RDEPEND}
index 1d737f2e39fd950252b63a1f7cb4dbaddc6daa3a..b7fe22f1c8b03393e491afec1c3bf52745ceab3d 100644 (file)
@@ -17,7 +17,7 @@ EGIT_REPO_URI="https://git.zx2c4.com/cgit"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS=""
-IUSE="doc +highlight +lua +jit"
+IUSE="doc +highlight +lua +luajit"
 
 RDEPEND="
        dev-vcs/git
@@ -25,7 +25,10 @@ RDEPEND="
        dev-libs/openssl:0
        virtual/httpd-cgi
        highlight? ( || ( dev-python/pygments app-text/highlight ) )
-       lua? ( jit? ( dev-lang/luajit ) !jit? ( dev-lang/lua:0 ) )
+       lua? (
+               luajit? ( dev-lang/luajit )
+               !luajit? ( dev-lang/lua:0 )
+       )
 "
 # ebuilds without WEBAPP_MANUAL_SLOT="yes" are broken
 DEPEND="${RDEPEND}