dev-db/freetds: Drop old
authorPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 10:35:28 +0000 (11:35 +0100)
committerPacho Ramos <pacho@gentoo.org>
Sun, 27 Jan 2019 11:05:21 +0000 (12:05 +0100)
Package-Manager: Portage-2.3.58, Repoman-2.3.12
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
dev-db/freetds/Manifest
dev-db/freetds/freetds-1.00.41.ebuild [deleted file]

index c4845e1fafd8c7f5896ee2ed40142e91184b6603..76ad01521eb2ce13a58c3734c2862793352b8343 100644 (file)
@@ -1,2 +1 @@
-DIST freetds-1.00.41.tar.gz 2904915 BLAKE2B d92789c9a08dc9f7f04e8efc828841c3cace0e5a3affd11d8751a785db70db79fedffb3745a681b960d30a11efbb4fa457805eb4f72444eecc20eb65d46e2d82 SHA512 dec3197a6478fc59b7386f9a7a562df8b581bba7184210c42f26827e957b9746e6820d687a9c6cbcd7c825fc5d4f556547c0483d06c786a064d5c4859db4daa1
 DIST freetds-dev.1.00.341.tar.gz 3002134 BLAKE2B c9396c1f205e13c9f3449bef19830cf3b6c2fa72539555ebd6bc1532c014472c862ba2ac7f495bee8f53d640d628c6b15bb50183585d43cf3dbbea4e314636d2 SHA512 fd691535dfa5c97463ff72056cfa5721557b71e41b6186ffcb08e193e51214cf966a33ee55b8e538a6f035aeeef14ac5b15fe8758f1afea9e1252a3b8951ba58
diff --git a/dev-db/freetds/freetds-1.00.41.ebuild b/dev-db/freetds/freetds-1.00.41.ebuild
deleted file mode 100644 (file)
index a68dba1..0000000
+++ /dev/null
@@ -1,72 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit autotools
-
-DESCRIPTION="Tabular Datastream Library"
-HOMEPAGE="http://www.freetds.org/"
-SRC_URI="ftp://ftp.freetds.org/pub/freetds/stable/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~ppc-macos"
-IUSE="gnutls iconv kerberos libressl mssql iodbc odbc ssl"
-RESTRICT="test"
-
-DEPEND="
-       gnutls? ( net-libs/gnutls )
-       iconv? ( virtual/libiconv )
-       iodbc? ( dev-db/libiodbc )
-       kerberos? ( virtual/krb5 )
-       odbc? ( dev-db/unixODBC )
-       ssl? (
-               !libressl? ( dev-libs/openssl:0 )
-               libressl? ( dev-libs/libressl )
-       )"
-
-# bind-tools is needed because the osql script calls "host".
-RDEPEND="${DEPEND}
-       net-dns/bind-tools
-       sys-apps/grep
-       sys-apps/sed
-       virtual/awk"
-
-src_prepare() {
-       default
-       # Fix the iodbc include path in the configure script. Otherwise, it
-       # can't find isql.h.
-       sed -ie 's:with_iodbc/include":with_iodbc/include/iodbc":' \
-               configure.ac \
-               || die "failed to fix the iodbc include path in configure.ac"
-       eautoreconf
-}
-
-src_configure() {
-       local myconf=( --with-tdsver=7.4 )
-
-       # The configure script doesn't support --without-{i,unix}odbc and
-       # it will still search for the associated headers if you try that
-       # Instead, to disable {i,unix}odbc, you just have to omit the
-       # --with-{i,unix}odbc line.
-       if use iodbc ; then
-               myconf+=( --enable-odbc --with-iodbc="${EPREFIX}/usr" )
-       fi
-
-       if use odbc ; then
-               myconf+=( --enable-odbc --with-unixodbc="${EPREFIX}/usr" )
-       fi
-
-       myconf+=( $(use_enable iconv libiconv) )
-       use iconv && myconf+=( --with-libiconv-prefix="${EPREFIX}/usr" )
-       myconf+=( $(use_enable kerberos krb5) )
-       myconf+=( $(use_enable mssql msdblib) )
-       myconf+=( $(use_with gnutls) )
-       myconf+=( $(use_with ssl openssl "${EPREFIX}/usr") )
-
-       # The docdir doesn't contain ${PV} without this
-       myconf+=( --docdir="/usr/share/doc/${PF}" )
-
-       econf "${myconf[@]}"
-}