dev-perl/Devel-PatchPerl: Bump to version 1.920.0
authorKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 09:52:08 +0000 (21:52 +1200)
committerKent Fredric <kentnl@gentoo.org>
Tue, 28 Apr 2020 11:38:58 +0000 (23:38 +1200)
- EAPI7

Upstream:
- Update hints
- Perform no patching if perl version GTE certified versions
- Patch configure for -fwrapv
- Patch utils/h2ph.PL
- Patch lib/h2ph.t
- Fix patch_source with perl 5.8.{1..8}
- Fix patching perl 5.20.3
- Temporarily switch patch targets from 0444 to 0644 where relevant
- Fix issues with perl 5.7.x
- Base64-encode patches
- Fix patching 5.8.8 on macOS
- Fix bug in SDBM_File on perls 5.10.0 to 5.14.4
- Fix build issues with ExtUtils::MM_AIX on perl 5.28.* and 5.30.*
- Fix Locale.t for year 2020 problem
- Fix issues building threaded/quadmath perls <5.28.0

Package-Manager: Portage-2.3.97, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Devel-PatchPerl/Devel-PatchPerl-1.920.0.ebuild [new file with mode: 0644]
dev-perl/Devel-PatchPerl/Manifest

diff --git a/dev-perl/Devel-PatchPerl/Devel-PatchPerl-1.920.0.ebuild b/dev-perl/Devel-PatchPerl/Devel-PatchPerl-1.920.0.ebuild
new file mode 100644 (file)
index 0000000..0122771
--- /dev/null
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=BINGOS
+DIST_VERSION=1.92
+inherit perl-module
+
+DESCRIPTION="Patch perl source a la Devel::PPPort's buildperl.pl"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-perl/File-pushd-1.0.0
+       virtual/perl-IO
+       virtual/perl-MIME-Base64
+       dev-perl/Module-Pluggable
+"
+BDEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PERL_RM_FILES=(
+       "t/author-pod-coverage.t"
+       "t/author-pod-syntax.t"
+)
index 6626d6d5762bc924f88fafc17b63ed296dac32fe..458b7a87b747292af75bd51c8ef69f718d9b3b88 100644 (file)
@@ -1 +1,2 @@
 DIST Devel-PatchPerl-1.52.tar.gz 123142 BLAKE2B 627bde1f894fdcc55a2db1d42cad93da65359d88922417a661b7719eba7f7f710bf5c1f6dc66e78830244b34d070e062b48b6736cd21549ace544b51ed2b7a1c SHA512 c08783fa087a2f6e55cc25665e429373c46fdb97ba0f08a4f20f71e8970d188281b41c04ed3d39c6fe7ea4b642cd6c3c08116bdbe0c9de0d4ce9fe64971d767f
+DIST Devel-PatchPerl-1.92.tar.gz 172986 BLAKE2B 177a6f5becc9d23cceedbea4a7b611cc101fac18d155d75f73ebb8b4b18a4ead4bf652edc8a5f5660f02c9bb32e0aa8ab345629503a58bf0d31bd825f2501d8a SHA512 54c1528b17b70df1ab2719ba272f9fd3c2f1de7867839bea762501d3100bd63986547d8a9eb20e0ffe55e6b0c7aae0bf8812de916fd0945ccc1a02944af6b690