dev-libs/hyperscan: correct python dependencies
authorPetr Vaněk <arkamar@atlas.cz>
Mon, 9 Mar 2020 09:08:43 +0000 (10:08 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Sat, 4 Apr 2020 07:38:58 +0000 (10:38 +0300)
Python is build time dependency only. It works perfectly with python3
and there is no need to depend on Python2.

Closes: https://bugs.gentoo.org/710218
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Petr Vaněk <arkamar@atlas.cz>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-libs/hyperscan/hyperscan-5.2.1-r1.ebuild [moved from dev-libs/hyperscan/hyperscan-5.2.1.ebuild with 80% similarity]

similarity index 80%
rename from dev-libs/hyperscan/hyperscan-5.2.1.ebuild
rename to dev-libs/hyperscan/hyperscan-5.2.1-r1.ebuild
index 8789fd913c7197c1c385858ce4148e6250a5e99c..aa7ab14e7067b07b046a37846724f8c5b783ced2 100644 (file)
@@ -3,9 +3,9 @@
 
 EAPI=7
 
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python3_{6..8} )
 
-inherit cmake python-r1 flag-o-matic
+inherit cmake flag-o-matic python-any-r1
 
 DESCRIPTION="High-performance regular expression matching library"
 SRC_URI="https://github.com/intel/hyperscan/archive/v${PV}.tar.gz -> ${P}.tar.gz"
@@ -16,12 +16,14 @@ SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="+cpu_flags_x86_ssse3 static-libs"
 
-RDEPEND="${PYTHON_DEPS}
-       dev-libs/boost"
+RDEPEND="dev-libs/boost"
 DEPEND="${RDEPEND}"
-BDEPEND="dev-util/ragel"
+BDEPEND="
+       ${PYTHON_DEPS}
+       dev-util/ragel
+"
 
-REQUIRED_USE="cpu_flags_x86_ssse3 ${PYTHON_REQUIRED_USE}"
+REQUIRED_USE="cpu_flags_x86_ssse3"
 
 src_prepare() {
        # upstream workaround