media-gfx/rawtherapee: Fix building with latest glibmm/libsigc++ (#568136)
authorPacho Ramos <pacho@gentoo.org>
Tue, 15 Dec 2015 20:02:04 +0000 (21:02 +0100)
committerPacho Ramos <pacho@gentoo.org>
Tue, 15 Dec 2015 20:16:30 +0000 (21:16 +0100)
Package-Manager: portage-2.2.26

media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch [new file with mode: 0644]
media-gfx/rawtherapee/rawtherapee-4.2.ebuild

diff --git a/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch b/media-gfx/rawtherapee/files/rawtherapee-4.2-cxx11.patch
new file mode 100644 (file)
index 0000000..48acb5f
--- /dev/null
@@ -0,0 +1,27 @@
+From 39ef59ddeb7679c71274b1da3faadd395b650c73 Mon Sep 17 00:00:00 2001
+From: Adam Reichold <adam.reichold@t-online.de>
+Date: Sun, 29 Nov 2015 11:48:30 +0100
+Subject: [PATCH] Build with '-std=c++11' if libsigc++ version 2.5.1 is used as
+ it does require it.
+
+---
+ CMakeLists.txt | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index dd5fcbc..6153484 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -278,10 +278,10 @@ if (OPTION_OMP)
+     endif (OPENMP_FOUND)
+ endif (OPTION_OMP)
+-if(USE_EXPERIMENTAL_LANG_VERSIONS)
++if(USE_EXPERIMENTAL_LANG_VERSIONS OR NOT (SIGC_VERSION VERSION_LESS 2.5.1))
+       SET (CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -std=gnu1x")
+       SET (CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -std=gnu++0x")
+-endif (USE_EXPERIMENTAL_LANG_VERSIONS)
++endif ()
+ # find out whether we are building out of source
+ get_filename_component(ABS_SOURCE_DIR "${PROJECT_SOURCE_DIR}" ABSOLUTE)
index 6ae07a579609e60f44591078627a9775c4bf8a2f..6702661a65271a72f39a4d718aba8aef1fed1d11 100644 (file)
@@ -33,6 +33,10 @@ DEPEND="${RDEPEND}
        app-arch/xz-utils
        virtual/pkgconfig"
 
+PATCHES=(
+        "${FILESDIR}"/${P}-cxx11.patch # Upstream patch for fixing bug #568136
+)
+
 pkg_pretend() {
        if use openmp ; then
                tc-has-openmp || die "Please switch to an openmp compatible compiler"