dev-util/rt-tests: Bump version to v1.7
authorKurt Kanzenbach <kurt@kmk-computers.de>
Fri, 28 Feb 2020 15:36:12 +0000 (16:36 +0100)
committerJoonas Niilola <juippis@gentoo.org>
Tue, 3 Mar 2020 14:53:43 +0000 (16:53 +0200)
Version v1.7 has been released a couple of days ago.

Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Kurt Kanzenbach <kurt@kmk-computers.de>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/rt-tests/Manifest
dev-util/rt-tests/rt-tests-1.7.ebuild [new file with mode: 0644]

index e0040c68a716d58ab8f608c25c6d725c04ff286f..35fa058295d6abcb6a656b6ccc0480714646aa04 100644 (file)
@@ -1 +1,2 @@
 DIST rt-tests-1.6.tar.xz 104864 BLAKE2B 36ada7cbe6deefae2eef80fa167892d41a9c56a6f54a23c8ace5ab97a32e23a88a488bc95f92456a7eea48c49567c4755adc43b3aa68e20c885ca1c354825a7d SHA512 1cbb9b1bc7f6ac335be269e5937209598bfb8c0a29750484e7bba8b87b416c04cd38c8d6d48dc5ed1978c1797dee4cecff0218124bd6d7f23b43a13dc7a75a29
+DIST rt-tests-1.7.tar.xz 106044 BLAKE2B 290f8ad871c809c840f834cbee3030ade04decf3649be9cb55b120b9e915664514f209c7979f070ce42486ed5fc2ba8dca66c7b08ebe87c312407147d65e7d16 SHA512 c1a257d71c4ee2c15b27eea720a6f0e8bdb118d706aa517e368ed28a9ccf94a16b863ceb37adde922a40fd7a023d2506c5cd19c31f1f78858fb20c2f2af22692
diff --git a/dev-util/rt-tests/rt-tests-1.7.ebuild b/dev-util/rt-tests/rt-tests-1.7.ebuild
new file mode 100644 (file)
index 0000000..3fd05e2
--- /dev/null
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{6,7,8})
+
+inherit python-single-r1
+
+DESCRIPTION="A collection of latency testing tools for the linux(-rt) kernel"
+HOMEPAGE="https://git.kernel.org/pub/scm/utils/rt-tests/rt-tests.git/about/"
+SRC_URI="
+       https://kernel.org/pub/linux/utils/rt-tests/${P}.tar.xz
+       https://kernel.org/pub/linux/utils/rt-tests/older/${P}.tar.xz"
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="numa"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+       numa? ( sys-process/numactl )"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+       emake $(usex numa 'NUMA=1' 'NUMA=0') all
+}
+
+src_install() {
+       emake prefix=/usr DESTDIR="${D}" MAN_COMPRESSION=none install
+       python_fix_shebang "${ED}"
+       python_optimize
+}