dev-libs/libnfc: drop old EAPI
authorAaron Bauman <bman@gentoo.org>
Thu, 14 Nov 2019 00:33:10 +0000 (19:33 -0500)
committerAaron Bauman <bman@gentoo.org>
Thu, 14 Nov 2019 00:33:10 +0000 (19:33 -0500)
Signed-off-by: Aaron Bauman <bman@gentoo.org>
dev-libs/libnfc/Manifest
dev-libs/libnfc/libnfc-1.4.2.ebuild [deleted file]
dev-libs/libnfc/libnfc-1.5.1-r1.ebuild [deleted file]

index b0e2f0ee4280c5800247ada227ee72b0fc352547..d9ffddf151823e161d26090df749273a8f3193fb 100644 (file)
@@ -1,3 +1 @@
-DIST libnfc-1.4.2.tar.gz 487310 BLAKE2B 9a92bebcdf5e28245b8087799d65ee67b3133d737aba781af19732bf839d16c40509ef5d87bca67a2946925a5265ad2b949bbbc93dd180c9b146615fae6e2483 SHA512 96710f1a808ab1cf90d86f687ec82339a3efab78253f840fba0188c01beadb326f1b521b67a8b7d47b217eae63ff6c5ec3906b4cbd743afa970aecf801b448ef
-DIST libnfc-1.5.1.tar.gz 534349 BLAKE2B b7d1654f596040dff81d8f6c42c9a587827051adb6883c70f51d6ed3a7839d981be921d0fac96697e18f66cdea93f1ca476bb48aae6e01d3ac9c8e59032e1820 SHA512 1b496b9368f0a19f5286c63c17ddf9c8afa3bae5106c8a85d89bbb8bb700948782722c30d9703d4348b45f362b47f5d63cbc0d7b4a4fe7d31dbbaedfa3354533
 DIST libnfc-1.7.1.tar.bz2 484309 BLAKE2B 7a86394e8902421410d54de2b2710cee7ea34a6f950f6d76ec59d24d6e46798cd10a9725f405c729df44da84b810b5853a5eef0ec5f2a10ccbcf7585d33f34ef SHA512 6a03d197c450c0ab8f2d16ae8c1f80e206fa909ece84a32dbb962acd0f7ef693a419608cdaa4c2207a1d2593599e44479520d7413eace7fca19d3230442e506c
diff --git a/dev-libs/libnfc/libnfc-1.4.2.ebuild b/dev-libs/libnfc/libnfc-1.4.2.ebuild
deleted file mode 100644 (file)
index 513d1ac..0000000
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils
-
-DESCRIPTION="Near Field Communications (NFC) library"
-HOMEPAGE="http://www.libnfc.org/"
-SRC_URI="https://github.com/nfc-tools/${PN}/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc"
-
-RDEPEND="sys-apps/pcsc-lite
-       virtual/libusb:0"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )"
-
-src_compile() {
-       emake || die "Failed to compile."
-       use doc && doxygen
-}
-
-src_install() {
-       emake install DESTDIR="${D}" || die "Failed to install properly."
-       use doc && dohtml "${S}"/doc/html/*
-}
diff --git a/dev-libs/libnfc/libnfc-1.5.1-r1.ebuild b/dev-libs/libnfc/libnfc-1.5.1-r1.ebuild
deleted file mode 100644 (file)
index 8621ed6..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Near Field Communications (NFC) library"
-HOMEPAGE="http://www.libnfc.org/"
-SRC_URI="https://github.com/nfc-tools/${PN}/releases/download/${P}/${P}.tar.gz"
-
-LICENSE="LGPL-3"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~x86"
-IUSE="doc pcsc-lite readline static-libs usb"
-
-RDEPEND="pcsc-lite? ( sys-apps/pcsc-lite )
-       readline? ( sys-libs/readline )
-       usb? ( virtual/libusb:0 )"
-DEPEND="${RDEPEND}
-       doc? ( app-doc/doxygen )"
-
-src_prepare() {
-       epatch "${FILESDIR}/${PN}-1.5.1-glibc-2.17.patch"
-}
-
-src_configure() {
-       # Upstream doesn't use the right macro, so we need to force this.
-       # https://code.google.com/p/libnfc/issues/detail?id=249
-       export ac_cv_path_PKG_CONFIG=$(tc-getPKG_CONFIG)
-
-       local drivers="arygon,pn532_uart"
-       use pcsc-lite && drivers+=",acr122"
-       use usb && drivers+=",pn53x_usb"
-       econf \
-               --with-drivers="${drivers}" \
-               $(use_enable doc) \
-               $(use_with readline) \
-               $(use_enable static-libs static)
-}
-
-src_compile() {
-       default
-       use doc && doxygen
-}
-
-src_install() {
-       default
-       use static-libs || find "${ED}" -name 'lib*.la' -delete
-       use doc && dohtml "${S}"/doc/html/*
-}