sys-process/atop: Bump to version 2.5.0
authorLars Wendler <polynomial-c@gentoo.org>
Mon, 4 Nov 2019 10:01:15 +0000 (11:01 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Mon, 4 Nov 2019 10:04:23 +0000 (11:04 +0100)
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
sys-process/atop/Manifest
sys-process/atop/atop-2.5.0.ebuild [new file with mode: 0644]
sys-process/atop/files/atop-2.5.0-install_fix.patch [new file with mode: 0644]

index d65dc64336bb98529618724a7e5c243db0e56a7c..8c799a1f8b9de8754a434f63bd8195cdc572d4cf 100644 (file)
@@ -3,3 +3,4 @@ DIST atop-2.3.0-version_c.patch 1537 BLAKE2B eda9f0aa427e39ef12aa1584e6277de0057
 DIST atop-2.3.0-version_h.patch 748 BLAKE2B 95aa0e819d35498436ddb2554f457e9bf74a70395f077d8f0625b52469d3f4a1f5793afc061aa1f7105fbea6223bb19bbcb999be4231b761523eb28cb5243542 SHA512 79ea49421e9bd82322cae26148d608560910a3d2e089228d2218d93744dcba8398058dd75255b64d15301c8bc4bde1dd6e15b6c6949a01534557b24b3d79089d
 DIST atop-2.3.0.tar.gz 190560 BLAKE2B 4c7a8f33f7e32fb6107275c21db54af91ffdb06cea14039ba85c6e844efc05e5c64708dae48eb3a7b8e075378838937ddd4756a954e6a040d4b3e8c4e7dd9e93 SHA512 8347f480b3e8f957be9aa8982b9c69c5fbc59b8a32044662995495cc2218de48342788aae40538d2ad67d402c8c470d0514261791ead70303f97221ea6983621
 DIST atop-2.4.0.tar.gz 230066 BLAKE2B 75070f0a87f9745f0e018ef5aac7e71060acea77e2043d43594a492875126945ef4c5bfe15f69b300ce6ac25c38f54360ba761ad7fc510016a91b71dc3377957 SHA512 8872626db447b2b7265fa257bc78795c3a5bc2f0dfffae94d01df4090de75feeb092e5a33421877aa12563dde3df18734b5db947c828cec6949284fbeb9dbc8d
+DIST atop-2.5.0.tar.gz 233835 BLAKE2B e40ae26cb1f8ddecbf6ea8f8f83d09bf9d62003a54e0679d5eefdf7c6fdaaff1940ba5f097fc1fc181ddb6aedcb8e1482feeb451cce5905b98c929c786db147d SHA512 8c50482194b60afedfd9d593ea7e916b63310bd3b43965fbd2769a2673f6f2247dec764ed1576866321a4b9c7301d5d8369c97fb6d351246395d01772ad04489
diff --git a/sys-process/atop/atop-2.5.0.ebuild b/sys-process/atop/atop-2.5.0.ebuild
new file mode 100644 (file)
index 0000000..001ca08
--- /dev/null
@@ -0,0 +1,69 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd toolchain-funcs
+
+DESCRIPTION="Resource-specific view of processes"
+HOMEPAGE="https://www.atoptool.nl/ https://github.com/Atoptool/atop"
+SRC_URI="https://github.com/Atoptool/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+       sys-libs/ncurses:0=
+       >=sys-process/acct-6.6.4-r1
+"
+DEPEND="
+       ${RDEPEND}
+"
+BDEPEND="
+       virtual/pkgconfig
+"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-2.4.0-build.patch
+       "${FILESDIR}"/${PN}-2.5.0-install_fix.patch
+
+       # taken from upstream.
+)
+
+pkg_pretend() {
+       if use kernel_linux ; then
+               CONFIG_CHECK="~BSD_PROCESS_ACCT"
+               check_extra_config
+       fi
+}
+
+src_prepare() {
+       default
+       tc-export CC PKG_CONFIG
+       sed -i 's: root : :' atop.cronsysv || die #191926
+       # prefixify
+       sed -i "s:/\(usr\|etc\|var\):${EPREFIX}/\1:g" Makefile || die
+}
+
+src_install() {
+       emake DESTDIR="${D}" genericinstall
+
+       # useless -${PV} copies ?
+       rm "${ED}"/usr/bin/atop*-${PV} || die
+
+       newinitd "${FILESDIR}"/${PN}.rc-r2 ${PN}
+       newinitd "${FILESDIR}"/atopacct.rc atopacct
+
+       systemd_dounit "${FILESDIR}"/${PN}.service
+       systemd_dounit "${FILESDIR}"/atopacct.service
+
+       dodoc atop.cronsysv AUTHOR README ${PN}.daily
+       docompress -x /usr/share/doc/${PF}/${PN}.daily
+
+       insinto /etc/default
+       newins ${PN}{.default,}
+
+       keepdir /var/log/${PN}
+}
diff --git a/sys-process/atop/files/atop-2.5.0-install_fix.patch b/sys-process/atop/files/atop-2.5.0-install_fix.patch
new file mode 100644 (file)
index 0000000..b46e88c
--- /dev/null
@@ -0,0 +1,31 @@
+From 485a453d2ae5700874a57dffc297030254b5ae7c Mon Sep 17 00:00:00 2001
+From: BlackEagle <ike.devolder@gmail.com>
+Date: Mon, 4 Nov 2019 09:00:54 +0100
+Subject: [PATCH] DEFPATH not created so touch fails
+
+```
+touch               /build/atop/pkg/atop/etc/default/atop
+touch: cannot touch '/build/atop/pkg/atop/etc/default/atop': No such file or directory
+```
+
+Add DEFPATH mkdir in genericinstall to make sure the folder
+`$(DESTDIR)/etc/default` exits
+
+Signed-off-by: BlackEagle <ike.devolder@gmail.com>
+---
+ Makefile | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/Makefile b/Makefile
+index 929b0d7..a662fd6 100644
+--- a/Makefile
++++ b/Makefile
+@@ -140,6 +140,8 @@ sysvinstall:       genericinstall
+ genericinstall:       atop atopacctd atopconvert
+               if [ ! -d $(DESTDIR)$(LOGPATH) ];               \
+               then    mkdir -p $(DESTDIR)$(LOGPATH); fi
++              if [ ! -d $(DESTDIR)$(DEFPATH) ];               \
++              then    mkdir -p $(DESTDIR)$(DEFPATH); fi
+               if [ ! -d $(DESTDIR)$(BINPATH) ];               \
+               then    mkdir -p $(DESTDIR)$(BINPATH); fi
+               if [ ! -d $(DESTDIR)$(SBINPATH) ];              \