dev-python/requests-mock: Bump to 1.8.0
authorMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 06:52:06 +0000 (08:52 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 3 May 2020 07:07:34 +0000 (09:07 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/requests-mock/Manifest
dev-python/requests-mock/requests-mock-1.8.0.ebuild [new file with mode: 0644]

index 4b9af0355f7e2f1459d7746aab76bb36547addff..19d7c0045158c823e9bfa215fea3d336d9ba3508 100644 (file)
@@ -1,2 +1,3 @@
 DIST requests-mock-1.5.2.tar.gz 47581 BLAKE2B 46beefc45e01355939a76b85e43a5b57cb1a870666eab7f610cad3e8a04a17da6a0864f9776a0f09028c847e8a4f7d0d2389a36f9a0431ed733a364d0f712c0b SHA512 206c91e892df84e38dcdf1264559128cfece76be2ce43b9c98238dfd438795d8c4ce3fcd43feb30246fbfca2d78832a23430ce1c9d3a7dc6e4417df5d65a8d3c
 DIST requests-mock-1.7.0.tar.gz 51705 BLAKE2B 1104422ab28678ee9e964fd853e7d61c23bc2f0dfb3861c2829578d1f91d533d195ce687fbc8596aba32da4b369050398d891125dc894e55fcb73ca81268b30c SHA512 6ad71fb87519f93812e8ae0d058a4b65a4492e86f05cacc37f95be1a6f0239a2c3f3d20a7e6f44bcc21f009574e4e78c2149394c2570d305efbdd68ec07b24a2
+DIST requests-mock-1.8.0.tar.gz 59794 BLAKE2B 2bdcd180ea793a02cf34eda356d90c0e338cec6f3fb718564026d28ea06ac975073f291be9cb685f012c803fdeca1fe29139537529e292b91a3356f0b781f97a SHA512 252bce965e0fca03cd5ce09912c726045f9c632e90bfee13b06c9f3e2c6b70eab7f39cf8e7efb3b7d2cf2b5d79cc5c5ba6e2379b3d48ce33bf78861ada911918
diff --git a/dev-python/requests-mock/requests-mock-1.8.0.ebuild b/dev-python/requests-mock/requests-mock-1.8.0.ebuild
new file mode 100644 (file)
index 0000000..e5e13b7
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Mock out responses from the requests package"
+HOMEPAGE="https://github.com/jamielennox/requests-mock"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+       >=dev-python/requests-2.3[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       >=dev-python/pbr-0.8[${PYTHON_USEDEP}]
+       test? (
+               dev-python/fixtures[${PYTHON_USEDEP}]
+               dev-python/mock[${PYTHON_USEDEP}]
+               dev-python/testtools[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests unittest
+
+python_prepare_all() {
+       # Disable reno which only works inside a git repository
+       sed -i "s/'reno.sphinxext',//" doc/source/conf.py || die
+       # Remove the release notes section which requires reno
+       rm doc/source/release-notes.rst || die
+       sed -i '/^=============$/,/release-notes/d' doc/source/index.rst || die
+       # Disable a test which requires purl (not in the tree)
+       sed -i -e "/^import purl$/d" -e "s/test_with_purl/_&/" \
+               tests/test_adapter.py || die
+       distutils-r1_python_prepare_all
+}