sci-geosciences/gnome-maps: bump to 3.34.3
authorMart Raudsepp <leio@gentoo.org>
Sat, 4 Jan 2020 09:52:09 +0000 (11:52 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sat, 4 Jan 2020 13:03:23 +0000 (15:03 +0200)
Package-Manager: Portage-2.3.79, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
sci-geosciences/gnome-maps/Manifest
sci-geosciences/gnome-maps/gnome-maps-3.34.3.ebuild [new file with mode: 0644]

index 9c453618b0c5b03eb360f7d8ee49ab99bffe2051..42f9fd00367ada314d1bc2d008d50dd94a95ff75 100644 (file)
@@ -1,2 +1,3 @@
 DIST gnome-maps-3.30.3.1.tar.xz 2175840 BLAKE2B 0c2f44ec3262715d98e1a0412ca305e15916cdb92df5fc5b04df34b65a7b9c55d4f5dd9c54f9f9dc34f8e6dd889f60d7993b59ca0cd92e4e60b22b506877b24c SHA512 02d3b1b305c1011a60a34566847962ec3c32ee3563ce2c327b810fae24c2df08354d8420f1986645d861cfef7a35f336d67d4576a3e2f61eabdd972b8d070a8e
 DIST gnome-maps-3.34.2.tar.xz 3973480 BLAKE2B b2a4ff993ccecb27c79599485278fdffcd64b22d5cdf011a73106e883c75b72e4a5160a1d5c05a1e9324ecd458371a5e512855dc1d59f14e06e711b00e4128f8 SHA512 8f7f88343bee22aff9d9e821d2059c4428788d9a43ada7415387721664a58fa1bc7ff36865fc7d12702e77fa794d87d3e3fb80aab694fb6c014fd4dbc1db0f0c
+DIST gnome-maps-3.34.3.tar.xz 3976776 BLAKE2B e01c18be2b48b90f88159828a046e3c422a56557f198595985ba39053ffdc85d60eebbf21d37ab1e4bb2eae8d1ad93c76b199650b713eba7a937674be38c845f SHA512 63261fb77ea1260aacaf502950f89ba6e5294271526b25302258df4fb40f4e04e3a4697750b2f7238f45a8d4bdbe9e583d45a4de02ce178e8f6716b44a7c8ba0
diff --git a/sci-geosciences/gnome-maps/gnome-maps-3.34.3.ebuild b/sci-geosciences/gnome-maps/gnome-maps-3.34.3.ebuild
new file mode 100644 (file)
index 0000000..cb81414
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="A map application for GNOME"
+HOMEPAGE="https://wiki.gnome.org/Apps/Maps"
+
+LICENSE="GPL-2+ LGPL-2+ MIT CC-BY-3.0 CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Pure introspection dependencies found by grepping imports.gi in ${S}
+RDEPEND="
+       >=dev-libs/glib-2.44.0:2
+       x11-libs/pango[introspection]
+       >=dev-libs/gjs-1.50.0
+       >=dev-libs/gobject-introspection-0.10.1:=
+       >=x11-libs/gtk+-3.22:3[introspection]
+       >=app-misc/geoclue-0.12.99:2.0[introspection]
+       >=dev-libs/libgee-0.16:0.8[introspection]
+       >=dev-libs/folks-0.10
+       >=sci-geosciences/geocode-glib-3.15.2[introspection]
+       >=media-libs/libchamplain-0.12.14:0.12[gtk,introspection]
+       dev-libs/libxml2:2
+       >=net-libs/rest-0.7.90:0.7[introspection]
+
+       app-crypt/libsecret[introspection]
+       dev-libs/libgweather[introspection]
+       media-libs/clutter-gtk:1.0[introspection]
+       media-libs/clutter:1.0[introspection]
+       net-libs/gnome-online-accounts[introspection]
+       net-libs/libgfbgraph[introspection]
+       net-libs/libsoup:2.4[introspection]
+       net-libs/webkit-gtk:4[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postinst() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}