projects
/
portage.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
1550325
)
Call settings.reset() in EbuildMetadataPhase.start() since that's what
author
Zac Medico
<zmedico@gentoo.org>
Fri, 11 Jul 2008 05:12:00 +0000
(
05:12
-0000)
committer
Zac Medico
<zmedico@gentoo.org>
Fri, 11 Jul 2008 05:12:00 +0000
(
05:12
-0000)
portdbapi does too before generating metadata, and without it, a previous
CATEGORY can leak into the ebuild env and corrupt it (breaks lots of packages
that reference $CATEGORY).
svn path=/main/trunk/; revision=11015
pym/_emerge/__init__.py
patch
|
blob
|
history
diff --git
a/pym/_emerge/__init__.py
b/pym/_emerge/__init__.py
index dce4ef8d8092f17a0185f96cd5a9e99164ea52c0..bde6d5cbee0606cbca7693caa6712d8ab2f9f6de 100644
(file)
--- a/
pym/_emerge/__init__.py
+++ b/
pym/_emerge/__init__.py
@@
-2312,6
+2312,7
@@
class EbuildMetadataPhase(SubProcess):
def start(self):
settings = self.settings
+ settings.reset()
ebuild_path = self.ebuild_path
debug = settings.get("PORTAGE_DEBUG") == "1"
master_fd = None