Call settings.reset() in EbuildMetadataPhase.start() since that's what
authorZac Medico <zmedico@gentoo.org>
Fri, 11 Jul 2008 05:12:00 +0000 (05:12 -0000)
committerZac Medico <zmedico@gentoo.org>
Fri, 11 Jul 2008 05:12:00 +0000 (05:12 -0000)
portdbapi does too before generating metadata, and without it, a previous
CATEGORY can leak into the ebuild env and corrupt it (breaks lots of packages
that reference $CATEGORY).

svn path=/main/trunk/; revision=11015

pym/_emerge/__init__.py

index dce4ef8d8092f17a0185f96cd5a9e99164ea52c0..bde6d5cbee0606cbca7693caa6712d8ab2f9f6de 100644 (file)
@@ -2312,6 +2312,7 @@ class EbuildMetadataPhase(SubProcess):
 
        def start(self):
                settings = self.settings
+               settings.reset()
                ebuild_path = self.ebuild_path
                debug = settings.get("PORTAGE_DEBUG") == "1"
                master_fd = None