dev-libs/amdgpu-pro-opencl: 18.20.606296 version bump
authorVladyslav Brovko <brovushkin+gentoo@gmail.com>
Sun, 24 Jun 2018 13:49:05 +0000 (15:49 +0200)
committerMarek Szuba <marecki@gentoo.org>
Tue, 26 Jun 2018 19:46:15 +0000 (20:46 +0100)
Closes: https://bugs.gentoo.org/656568
Package-Manager: Portage-2.3.36, Repoman-2.3.9
Revised-by: Marek Szuba <marecki@gentoo.org>
dev-libs/amdgpu-pro-opencl/Manifest
dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild [new file with mode: 0644]

index df04d9e18fffafa80c441cf24f5dff1ec07decc1..76477531154542528925b4ab0cd7a6c1ff3f4def 100644 (file)
@@ -1 +1,2 @@
 DIST amdgpu-pro-17.50-511655.tar.xz 547875548 BLAKE2B c3e396d9846ca15297ecbfd8ff1c9ca3aae6352080f280dc13f2ad4d32da7b84a6d069fd4b64c6e4d9814459cc5cca1ab838295a83ede953a9df6cdcd1387f91 SHA512 d4d995eb596f94656d2fb6e43a2db29bcbfe28e09f75e19e23d1d446de899dbb6e4597ef833955a8b1788055fa848bc14e45a32c820ed8e97c667a784cf816cc
+DIST amdgpu-pro-18.20-606296.tar.xz 230733856 BLAKE2B 21a498a894a9712d9f0277fae7f704413be0cd01cebbe427008fa3d181d03b58268e74bd3cdaf0dfb9aeca2871dad82b4aa640bbce690ca461e3f3e4acf01ffd SHA512 6575bf963e5714657914d9116de4d9b1835851fe0609b1f072b1fbdf73c068da77aba0eca1c9cce6e05e6cd8f2c1ed6b4bd6ab4ef334be5ff796ee6a3ad73831
diff --git a/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild b/dev-libs/amdgpu-pro-opencl/amdgpu-pro-opencl-18.20.606296.ebuild
new file mode 100644 (file)
index 0000000..614f397
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit unpacker
+
+SUPER_PN='amdgpu-pro'
+MY_PV=$(ver_rs 2 '-')
+
+DESCRIPTION="Proprietary OpenCL implementation for AMD GPUs"
+HOMEPAGE="https://support.amd.com/en-us/kb-articles/Pages/Radeon-Software-for-Linux-Release-Notes.aspx"
+SRC_URI="${SUPER_PN}-${MY_PV}.tar.xz"
+
+LICENSE="AMD-GPU-PRO-EULA"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RESTRICT="mirror fetch strip"
+
+DEPEND=""
+RDEPEND="dev-libs/ocl-icd"
+
+QA_PREBUILT="/opt/${SUPER_PN}/lib*/*"
+
+S="${WORKDIR}/${SUPER_PN}-${MY_PV}"
+
+pkg_nofetch() {
+       local pkgver=$(ver_cut 1-2)
+       einfo "Please download the Radeon Software for Linux Driver ${pkgver} for Ubuntu 16 from"
+       einfo "    ${HOMEPAGE}"
+       einfo "The archive should then be placed into ${DISTDIR}."
+}
+
+src_unpack() {
+       default
+
+       cd "${S}" || die
+       unpack_deb opencl-orca-amdgpu-pro-icd_${MY_PV}_amd64.deb
+}
+
+src_install() {
+       into "/opt/amdgpu"
+       dolib.so opt/${SUPER_PN}/lib/x86_64-linux-gnu/*
+
+       insinto /etc/OpenCL/vendors/
+       echo "/opt/amdgpu/$(get_libdir)/libamdocl-orca64.so" > "${SUPER_PN}.icd" || die "Failed to generate ICD file"
+       doins "${SUPER_PN}.icd"
+}
+
+pkg_postinst() {
+       if [[ -z "${REPLACING_VERSIONS}" ]]; then
+               ewarn "Please note that using proprietary OpenCL libraries together with the"
+               ewarn "Open Source amdgpu stack is not officially supported by AMD. Do not ask them"
+               ewarn "for support in case of problems with this package."
+               ewarn ""
+               ewarn "Furthermore, if you have the whole AMDGPU-Pro stack installed this package"
+               ewarn "will almost certainly conflict with it. This might change once AMDGPU-Pro"
+               ewarn "has become officially supported by Gentoo."
+       fi
+
+       elog "AMD OpenCL driver relies on dev-libs/ocl-icd to work. To enable it, please run"
+       elog ""
+       elog "    eselect opencl set ocl-icd"
+       elog ""
+}