sys-apps/selinux-python: update live ebuild
authorJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 08:33:04 +0000 (16:33 +0800)
committerJason Zaman <perfinion@gentoo.org>
Thu, 23 Feb 2017 11:14:30 +0000 (19:14 +0800)
need to pass the path to libsepol.a

Package-Manager: portage-2.3.3

sys-apps/selinux-python/selinux-python-9999.ebuild

index 556173cabf3aa54441f295211ce45b94810e7f97..84a858b5e4e10c14b942b989709e9c43b5449f7b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -62,9 +62,10 @@ src_compile() {
 
 src_install() {
        installation() {
-               emake -C "${BUILD_DIR}" DESTDIR="${D}" \
+               emake -C "${BUILD_DIR}" \
+                       DESTDIR="${D}" \
                        LIBDIR="\$(PREFIX)/$(get_libdir)" \
-                       PYLIBVER="${EPYTHON}" \
+                       LIBSEPOLA="/usr/$(get_libdir)/libsepol.a" \
                        install
                python_optimize
        }