dev-perl/Parallel-Iterator: Fix tests without '.' in @INC bug #615726
authorKent Fredric <kentnl@gentoo.org>
Fri, 22 Dec 2017 23:56:32 +0000 (12:56 +1300)
committerKent Fredric <kentnl@gentoo.org>
Fri, 22 Dec 2017 23:56:47 +0000 (12:56 +1300)
- Add USE=examples
- Update CPAN remote-id's

Bug: https://bugs.gentoo.org/615726
Package-Manager: Portage-2.3.18, Repoman-2.3.6

dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild [new file with mode: 0644]
dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch [new file with mode: 0644]
dev-perl/Parallel-Iterator/metadata.xml

diff --git a/dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild b/dev-perl/Parallel-Iterator/Parallel-Iterator-1.0.0-r1.ebuild
new file mode 100644 (file)
index 0000000..1bbc40a
--- /dev/null
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=ANDYA
+DIST_VERSION=1.00
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Simple parallel execution"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+       virtual/perl-IO
+       virtual/perl-Storable
+"
+DEPEND="${RDEPEND}
+       dev-perl/Module-Build
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
+PATCHES=("${FILESDIR}/${PN}-1.00-perl-5.26.patch")
diff --git a/dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch b/dev-perl/Parallel-Iterator/files/Parallel-Iterator-1.00-perl-5.26.patch
new file mode 100644 (file)
index 0000000..6605371
--- /dev/null
@@ -0,0 +1,57 @@
+From 3cf3250d8d62b93b83a34df309d1181f36a5e2ab Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sat, 23 Dec 2017 12:40:14 +1300
+Subject: Fix test failures without '.' in @INC
+
+Bug: https://rt.cpan.org/Public/Bug/Display.html?id=120543
+Bug: https://bugs.gentoo.org/615726
+---
+ t/050-nofork-basic.t | 2 +-
+ t/060-nofork-data.t  | 2 +-
+ t/070-nofork-block.t | 2 +-
+ t/080-nofork-batch.t | 2 +-
+ 4 files changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/t/050-nofork-basic.t b/t/050-nofork-basic.t
+index 1409174..2d2e454 100644
+--- a/t/050-nofork-basic.t
++++ b/t/050-nofork-basic.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+ use NoFork;
+-require 't/020-data.t';
++require './t/020-data.t';
+diff --git a/t/060-nofork-data.t b/t/060-nofork-data.t
+index 281cd07..1654671 100644
+--- a/t/060-nofork-data.t
++++ b/t/060-nofork-data.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+ use NoFork;
+-require 't/020-data.t';
++require './t/020-data.t';
+diff --git a/t/070-nofork-block.t b/t/070-nofork-block.t
+index a3dfb52..40b7342 100644
+--- a/t/070-nofork-block.t
++++ b/t/070-nofork-block.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+ use NoFork;
+-require 't/030-block.t';
++require './t/030-block.t';
+diff --git a/t/080-nofork-batch.t b/t/080-nofork-batch.t
+index 5d66b5c..d7c7165 100644
+--- a/t/080-nofork-batch.t
++++ b/t/080-nofork-batch.t
+@@ -3,4 +3,4 @@ use strict;
+ use lib 't/lib';
+ use NoFork;
+-require 't/040-batch.t';
++require './t/040-batch.t';
+-- 
+2.15.1
+
index 51930499ab60c43adb5c98391c24d5bf010b93e1..6641df0dba9b56c69b61c6b1bb5612c4736a82b6 100644 (file)
@@ -5,4 +5,8 @@
                <email>perl@gentoo.org</email>
                <name>Gentoo Perl Project</name>
        </maintainer>
+       <upstream>
+               <remote-id type="cpan">Parallel-Iterator</remote-id>
+               <remote-id type="cpan-module">Parallel::Iterator</remote-id>
+       </upstream>
 </pkgmetadata>