app-misc/wcd: Bump to version 5.3.0
authorLars Wendler <polynomial-c@gentoo.org>
Thu, 24 Sep 2015 08:02:49 +0000 (10:02 +0200)
committerLars Wendler <polynomial-c@gentoo.org>
Thu, 24 Sep 2015 08:03:10 +0000 (10:03 +0200)
Permission kindly granted by jlec.

Package-Manager: portage-2.2.21
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
app-misc/wcd/Manifest
app-misc/wcd/wcd-5.3.0.ebuild [new file with mode: 0644]

index be0d9b6cf252b3c49f5d759740695a9773f821b8..261daea6aa3cd2fbf78993191dea96248809a308 100644 (file)
@@ -1 +1,2 @@
 DIST wcd-5.2.7.tar.gz 622613 SHA256 e5f56824e054c6726186271b20a5de3c5b167116b97785a925907981cf3e3b39 SHA512 9f5b89d8160f685b729234cc8c03f16b795797dd6eaf2d9e1bbf1949b27ef971908b78642679d3bf1d99b128b390cd5dbd211e4ff03b0539dd287c578088e02e WHIRLPOOL 3354e380dceaed394e0eb9bac3f474edc819270a117baf5812a1e7252b2cef207862746af2b21dd71de837459bc6281a45a9099f5a6351def49e3c1ce780960d
+DIST wcd-5.3.0.tar.gz 617825 SHA256 9375c9b055e0ebff8d0b0a11673229bb9770071bda76249cf2494532794ecd9b SHA512 76f7039428a2792e200a4b070df2e861a5ad5c3a24b26348438974c0dd7bb564a1d495215d07920313da296bb704e5cd4708dc82c1ed2a2f1d79a268b5bb9610 WHIRLPOOL e19431a44e14fb0974e878ddd77800515846e46411415e2eb5db1e8dcf4d6df51e5373203196395d54439ca3b3aae6bc23e12afaf21920452acf1362a670d32d
diff --git a/app-misc/wcd/wcd-5.3.0.ebuild b/app-misc/wcd/wcd-5.3.0.ebuild
new file mode 100644 (file)
index 0000000..6d6877d
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Wherever Change Directory"
+HOMEPAGE="http://waterlan.home.xs4all.nl/#WCD_ANCHOR"
+SRC_URI="http://waterlan.home.xs4all.nl/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+IUSE="nls unicode"
+
+CDEPEND="
+       sys-libs/ncurses:0=[unicode?]
+       unicode? ( dev-libs/libunistring )"
+DEPEND="${CDEPEND}
+       app-text/ghostscript-gpl"
+RDEPEND="${CDEPEND}"
+
+S="${WORKDIR}"/${P}/src
+
+src_prepare() {
+       epatch \
+               "${FILESDIR}"/${PN}-5.2.5-gentoo.patch
+       tc-export CC
+}
+
+src_compile() {
+       local mycompile="LFS=1"
+       use nls || mycompile="${mycompile} ENABLE_NLS="
+       use unicode && mycompile="${mycompile} UCS=1 UNINORM=1"
+       emake \
+               ${mycompile}
+}
+
+src_install() {
+       local DOCS="../README.txt"
+       default
+       emake DESTDIR="${D}" DOTWCD=1 install-profile sysconfdir="/etc"
+}