sys-apps/file: rev bump
authorThomas Deutschmann <whissi@gentoo.org>
Sun, 12 Apr 2020 23:20:25 +0000 (01:20 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Sun, 12 Apr 2020 23:21:49 +0000 (01:21 +0200)
- Revert https://github.com/file/file/commit/24c9c086cd7c55b7b0a003a145b32466468e2608
  which fixes misdetection of shared libraries as statically linked as.

- Cherry-pick https://github.com/file/file/commit/d955cefc956ba537cfc0556023a65fe80bd2d82b

- Cherry-pick https://github.com/file/file/commit/483e7d8f1a5c3544bd42ead471813f8389fa7fc2

Bug: https://bugs.gentoo.org/717264
Package-Manager: Portage-2.3.98, Repoman-2.3.22
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sys-apps/file/file-5.38-r1.ebuild [new file with mode: 0644]
sys-apps/file/files/file-5.38-Revert-PR-93-iaeiaeiaeiae-Do-as-the-comment-says-and.patch [new file with mode: 0644]
sys-apps/file/files/file-5.38-The-executable-bit-is-only-set-when-DF_1_PIE-bit-is-.patch [new file with mode: 0644]
sys-apps/file/files/file-5.38-td-is-for-ptrdiff_t-not-for-off_t.patch [new file with mode: 0644]

diff --git a/sys-apps/file/file-5.38-r1.ebuild b/sys-apps/file/file-5.38-r1.ebuild
new file mode 100644 (file)
index 0000000..58bb745
--- /dev/null
@@ -0,0 +1,142 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{6,7,8} )
+DISTUTILS_OPTIONAL=1
+
+inherit distutils-r1 libtool toolchain-funcs multilib-minimal
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/glensc/file.git"
+       inherit autotools git-r3
+else
+       SRC_URI="ftp://ftp.astron.com/pub/file/${P}.tar.gz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+fi
+
+DESCRIPTION="identify a file's format by scanning binary data for patterns"
+HOMEPAGE="https://www.darwinsys.com/file/"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE="bzip2 lzma python static-libs zlib"
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+DEPEND="
+       bzip2? ( app-arch/bzip2[${MULTILIB_USEDEP}] )
+       lzma? ( app-arch/xz-utils[${MULTILIB_USEDEP}] )
+       python? (
+               ${PYTHON_DEPS}
+               dev-python/setuptools[${PYTHON_USEDEP}]
+       )
+       zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )"
+RDEPEND="${DEPEND}
+       python? ( !dev-python/python-magic )"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-Revert-PR-93-iaeiaeiaeiae-Do-as-the-comment-says-and.patch
+       "${FILESDIR}"/${P}-td-is-for-ptrdiff_t-not-for-off_t.patch
+       "${FILESDIR}"/${P}-The-executable-bit-is-only-set-when-DF_1_PIE-bit-is-.patch
+)
+
+src_prepare() {
+       default
+
+       [[ ${PV} == "9999" ]] && eautoreconf
+       elibtoolize
+
+       # don't let python README kill main README #60043
+       mv python/README.md python/README.python.md || die
+       sed 's@README.md@README.python.md@' -i python/setup.py || die #662090
+}
+
+multilib_src_configure() {
+       local myeconfargs=(
+               --disable-libseccomp
+               --enable-fsect-man5
+               $(use_enable bzip2 bzlib)
+               $(use_enable lzma xzlib)
+               $(use_enable static-libs static)
+               $(use_enable zlib)
+       )
+       econf "${myeconfargs[@]}"
+}
+
+build_src_configure() {
+       local myeconfargs=(
+               --disable-shared
+               --disable-libseccomp
+               --disable-bzlib
+               --disable-xzlib
+               --disable-zlib
+       )
+       tc-env_build econf "${myeconfargs[@]}"
+}
+
+need_build_file() {
+       # when cross-compiling, we need to build up our own file
+       # because people often don't keep matching host/target
+       # file versions #362941
+       tc-is-cross-compiler && ! has_version -b "~${CATEGORY}/${P}"
+}
+
+src_configure() {
+       local ECONF_SOURCE=${S}
+
+       if need_build_file; then
+               mkdir -p "${WORKDIR}"/build || die
+               cd "${WORKDIR}"/build || die
+               build_src_configure
+       fi
+
+       multilib-minimal_src_configure
+}
+
+multilib_src_compile() {
+       if multilib_is_native_abi ; then
+               emake
+       else
+               cd src || die
+               emake magic.h #586444
+               emake libmagic.la
+       fi
+}
+
+src_compile() {
+       if need_build_file; then
+               emake -C "${WORKDIR}"/build/src magic.h #586444
+               emake -C "${WORKDIR}"/build/src file
+               local -x PATH="${WORKDIR}/build/src:${PATH}"
+       fi
+       multilib-minimal_src_compile
+
+       if use python ; then
+               cd python || die
+               distutils-r1_src_compile
+       fi
+}
+
+multilib_src_install() {
+       if multilib_is_native_abi ; then
+               default
+       else
+               emake -C src install-{nodist_includeHEADERS,libLTLIBRARIES} DESTDIR="${D}"
+       fi
+}
+
+multilib_src_install_all() {
+       dodoc ChangeLog MAINT README
+
+       # Required for `file -C`
+       dodir /usr/share/misc/magic
+       insinto /usr/share/misc/magic
+       doins -r magic/Magdir/*
+
+       if use python ; then
+               cd python || die
+               distutils-r1_src_install
+       fi
+       find "${ED}" -type f -name "*.la" -delete || die
+}
diff --git a/sys-apps/file/files/file-5.38-Revert-PR-93-iaeiaeiaeiae-Do-as-the-comment-says-and.patch b/sys-apps/file/files/file-5.38-Revert-PR-93-iaeiaeiaeiae-Do-as-the-comment-says-and.patch
new file mode 100644 (file)
index 0000000..240edc1
--- /dev/null
@@ -0,0 +1,40 @@
+From c9d21a58bea2ecb2dc8876e09e471094d54a25e4 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Mon, 13 Apr 2020 01:08:12 +0200
+Subject: [PATCH 1/3] Revert "PR/93: iaeiaeiaeiae: Do as the comment says, and
+ count as dynamically linked"
+
+This reverts commit 24c9c086cd7c55b7b0a003a145b32466468e2608.
+
+Fixes misdetection of shared libraries as statically linked as
+reported in bug 717264.
+
+Bug: https://bugs.gentoo.org/717264
+Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
+---
+ src/readelf.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/readelf.c b/src/readelf.c
+index 40bcfab1..afec31d1 100644
+--- a/src/readelf.c
++++ b/src/readelf.c
+@@ -1638,6 +1638,7 @@ dophn_exec(struct magic_set *ms, int clazz, int swap, int fd, off_t off,
+               /* Things we can determine before we seek */
+               switch (xph_type) {
+               case PT_DYNAMIC:
++                      linking_style = "dynamically";
+                       doread = 1;
+                       break;
+               case PT_NOTE:
+@@ -1653,7 +1654,6 @@ dophn_exec(struct magic_set *ms, int clazz, int swap, int fd, off_t off,
+                       }
+                       /*FALLTHROUGH*/
+               case PT_INTERP:
+-                      linking_style = "dynamically";
+                       doread = 1;
+                       break;
+               default:
+-- 
+2.26.0
+
diff --git a/sys-apps/file/files/file-5.38-The-executable-bit-is-only-set-when-DF_1_PIE-bit-is-.patch b/sys-apps/file/files/file-5.38-The-executable-bit-is-only-set-when-DF_1_PIE-bit-is-.patch
new file mode 100644 (file)
index 0000000..bb211f3
--- /dev/null
@@ -0,0 +1,29 @@
+From ed971e5e3ae79bd28697d16c8b78b693052484e4 Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Wed, 12 Feb 2020 22:17:33 +0000
+Subject: [PATCH 3/3] The executable bit is only set when DF_1_PIE bit is set
+ so it is fine.
+
+---
+ magic/Magdir/elf | 7 ++++---
+ 1 file changed, 4 insertions(+), 3 deletions(-)
+
+diff --git a/magic/Magdir/elf b/magic/Magdir/elf
+index b5a2e00b..f5e1af9a 100644
+--- a/magic/Magdir/elf
++++ b/magic/Magdir/elf
+@@ -50,8 +50,9 @@
+ !:mime        application/x-object
+ >16   leshort         2               executable,
+ !:mime        application/x-executable
+->16   leshort         3               shared object,
+-!:mime        application/x-sharedlib
++>16   leshort         3               ${x?pie executable:shared object},
++
++!:mime        application/x-${x?pie-executable:sharedlib}
+ >16   leshort         4               core file,
+ !:mime        application/x-coredump
+ # OS-specific
+-- 
+2.26.0
+
diff --git a/sys-apps/file/files/file-5.38-td-is-for-ptrdiff_t-not-for-off_t.patch b/sys-apps/file/files/file-5.38-td-is-for-ptrdiff_t-not-for-off_t.patch
new file mode 100644 (file)
index 0000000..09fcaef
--- /dev/null
@@ -0,0 +1,27 @@
+From c49dc91df427f89ebcf9cdec556b8fc88cdfc3c1 Mon Sep 17 00:00:00 2001
+From: Christos Zoulas <christos@zoulas.com>
+Date: Tue, 17 Dec 2019 15:27:27 +0000
+Subject: [PATCH 2/3] %td is for ptrdiff_t not for off_t.
+
+---
+ src/readelf.c | 6 +++---
+ 1 file changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/src/readelf.c b/src/readelf.c
+index afec31d1..8ac3b7d6 100644
+--- a/src/readelf.c
++++ b/src/readelf.c
+@@ -1349,8 +1349,8 @@ doshn(struct magic_set *ms, int clazz, int swap, int fd, off_t off, int num,
+       name_off = xsh_offset;
+       if (fsize != SIZE_UNKNOWN && fsize < name_off) {
+-              if (file_printf(ms, ", too large section header offset %td",
+-                  name_off) == -1)
++              if (file_printf(ms, ", too large section header offset %jd",
++                  (intmax_t)name_off) == -1)
+                       return -1;
+               return 0;
+       }
+-- 
+2.26.0
+