sys-apps/opentmpfiles: 0.1.2 version bump for #610732
authorWilliam Hubbs <williamh@gentoo.org>
Fri, 24 Feb 2017 21:29:13 +0000 (15:29 -0600)
committerWilliam Hubbs <williamh@gentoo.org>
Fri, 24 Feb 2017 21:48:45 +0000 (15:48 -0600)
This is going direct to stable to fix stable 0.1.1.

Package-Manager: Portage-2.3.3, Repoman-2.3.1
RepoMan-Options: --force

sys-apps/opentmpfiles/Manifest
sys-apps/opentmpfiles/opentmpfiles-0.1.2.ebuild [new file with mode: 0644]

index 7246ff8e667819bb356786d8da4bab9220eccc7b..b2902bc370193f6f5a4e68c1604625276fbbdae3 100644 (file)
@@ -1,2 +1,3 @@
 DIST opentmpfiles-0.1.1.tar.gz 5626 SHA256 903cdf8eca5ff9577b10fb569cf5f01a132d2c02769ba3536ecf1ba23b05e184 SHA512 9b8bc74c642c42e4591cc98df096f2d74d14acc5e795f49026b37401c795861ffcdf8d505f6e62980bab1cc4ee2b182668bcd5d4f4cea0984b46662643d6a0d5 WHIRLPOOL a2223a5a101b70442e8ac3fa393c93724589738bfe3d899c9843d1f8cfa42db602212771f58e8387083e7e4929dde4b2dc5439eaaf7e071be3e21b6284b81962
+DIST opentmpfiles-0.1.2.tar.gz 5614 SHA256 63f05adca95ea63fa555d371e8a5d74fe633088893be3a63bff2cdabb7b6bb3b SHA512 d86ba71e5fe96d7a8e1999e14b0b99c78e850c42fbfefd203916edca593d0269feaf2252aa01cc35a838906fc2909015430f72cde8370e2d5b1d478a11fe456d WHIRLPOOL ca349478cb0f0ca565c007b8315e7970c84d628edaf7088e53037679cafb46513cb284ac8c30cb383245368185a6ad6e27cd11c36f7c4c299a774fca856b0e4c
 DIST opentmpfiles-0.1.tar.gz 5592 SHA256 0c7a52d6394dcbe78dd5b4f8fba6fcc66b207389b9a9b85e61a0ab8e9e375bb7 SHA512 f89e0b996a282ba39f5db7d5cf8e3b72672ba2a9f6013512b7169da9886d9d1d00d4de7c68aefdf2afcf24063283183c37a40864b89d25f68484b022fce58773 WHIRLPOOL 307e6094c0e74ceeb15fe84b09e5ea28b47584eb98a7384b9fa18e66ee7d2c2cc6e574fd2142d6373ff0cf8b302f266a2f277f74d6609d213daf0e92198caba4
diff --git a/sys-apps/opentmpfiles/opentmpfiles-0.1.2.ebuild b/sys-apps/opentmpfiles/opentmpfiles-0.1.2.ebuild
new file mode 100644 (file)
index 0000000..0e879f6
--- /dev/null
@@ -0,0 +1,47 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+if [[ ${PV} = 9999* ]]; then
+       inherit git-r3
+       EGIT_REPO_URI="git://github.com/openrc/${PN}"
+else
+       SRC_URI="https://github.com/openrc/${PN}/archive/${PV}.tar.gz ->
+               ${P}.tar.gz"
+       KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 m68k ~mips ppc ppc64 s390 sh ~sparc x86"
+fi
+
+DESCRIPTION="A standalone utility to process systemd-style tmpfiles.d files"
+HOMEPAGE="https://github.com/openrc/opentmpfiles"
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="!<sys-apps/openrc-0.23"
+
+src_install() {
+       default
+       cd openrc
+       for f in opentmpfiles-dev opentmpfiles-setup; do
+               newconfd ${f}.confd ${f}
+               newinitd ${f}.initd ${f}
+       done
+}
+
+add_service() {
+       local initd=$1
+       local runlevel=$2
+
+       elog "Auto-adding '${initd}' service to your ${runlevel} runlevel"
+       ln -snf /etc/init.d/${initd} "${EROOT}"etc/runlevels/${runlevel}/${initd}
+}
+
+pkg_postinst() {
+       if [[ -z $REPLACING_VERSIONS ]]; then
+               add_service opentmpfiles-dev sysinit
+               add_service opentmpfiles-setup boot
+       fi
+}