sci-mathematics/wxmaxima: bump to 20.01.1
authorAndrey Grozin <grozin@gentoo.org>
Sun, 5 Jan 2020 15:57:21 +0000 (22:57 +0700)
committerAndrey Grozin <grozin@gentoo.org>
Sun, 5 Jan 2020 15:57:21 +0000 (22:57 +0700)
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Andrey Grozin <grozin@gentoo.org>
sci-mathematics/wxmaxima/Manifest
sci-mathematics/wxmaxima/wxmaxima-20.01.1.ebuild [new file with mode: 0644]

index e3d59779b043f36582b4c43dced6bbf0f49534db..416af68ce1fd561a7268731740093c8359ebf48a 100644 (file)
@@ -1,2 +1,3 @@
 DIST wxmaxima-18.11.4.tar.gz 12156776 BLAKE2B 75be0fb88402af011885616a646f7abcad25516ea9b0b375daf02edac5518b113188290262bc431e8bfb4836fc1f731982a1c41c62871818e4d2cc68c96ccb31 SHA512 964de93edc5c46e98de3de405b1873fa0ed594d54f1ddc030377b023110261cb1e6b0b08dbf210551888bf890e28d16e9b1698768c93dde413d5e1918cbd234e
 DIST wxmaxima-19.12.2.tar.gz 15765011 BLAKE2B fa788a9b5c204a06f85f84a89548af3b846e3e06f572df2b0f2d74aaf6dbfea98b26d8bbfd7c1c62ab8a0aa376d1af9d37bce563b474f5badf2a2bde43135d61 SHA512 5614f78f169eb1cacb46ae46ddb754103aa85cf90b309fffece4543fc06c600e967e2ea73bb8b82065075ded82fea44ccd709be651f5075e3b91edb304ad5ab6
+DIST wxmaxima-20.01.1.tar.gz 14011946 BLAKE2B ed80f02158aa0c43f37c040225010b35eea49756d8f052bcfa245d31a4a2203880463f51833ed40f2e1365473eb138269287c30a52e9f9b98ef4d9a5daac8cf5 SHA512 bff946f87db39b4bf416ef3440fdfea277f9dc9ed95debcea5798211299ae8c8dbb136a44be586a79e538b99fd38c46febf5378caab6ac31a01a01033f083937
diff --git a/sci-mathematics/wxmaxima/wxmaxima-20.01.1.ebuild b/sci-mathematics/wxmaxima/wxmaxima-20.01.1.ebuild
new file mode 100644 (file)
index 0000000..9a2b704
--- /dev/null
@@ -0,0 +1,49 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+WX_GTK_VER="3.0"
+PLOCALES="ca cs da de el en es fi fr gl hu it ja kab nb pl pt_BR ru tr uk zh_CN zh_TW"
+inherit cmake-utils wxwidgets l10n xdg
+
+DESCRIPTION="Graphical frontend to Maxima, using the wxWidgets toolkit"
+HOMEPAGE="https://wxmaxima-developers.github.io/wxmaxima/"
+SRC_URI="https://github.com/wxMaxima-developers/wxmaxima/archive/Version-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}"/${PN}-Version-${PV}
+
+DEPEND="
+       dev-libs/libxml2:2
+       x11-libs/wxGTK:${WX_GTK_VER}"
+RDEPEND="${DEPEND}
+       media-fonts/jsmath
+       sci-visualization/gnuplot[wxwidgets]
+       sci-mathematics/maxima"
+
+src_prepare() {
+       setup-wxwidgets
+       cmake-utils_src_prepare
+
+       sed -e "s|share/doc/${PN}|share/doc/${PF}|g" -i "${S}"/info/CMakeLists.txt \
+               || die "sed info/CMakeLists.txt failed"
+
+       # locales
+       rm_po() {
+               rm "${S}"/locales/wxMaxima/${1}.po || die "rm ${1}.po failed"
+               rm -f "${S}"/locales/manual/${1}.po
+               rm -f "${S}"/locales/wxwin/${1}.po
+               rm -f "${S}"/info/${PN}.${1}.md
+               rm -f "${S}"/info/${PN}.${1}.html
+       }
+       l10n_find_plocales_changes "${S}"/locales/wxMaxima '' '.po'
+       l10n_for_each_disabled_locale_do rm_po
+}
+
+src_install() {
+       docompress -x /usr/share/doc/${PF}
+       cmake-utils_src_install
+}