dev-python/cryptography: Use virtual/python-enum34
authorMichał Górny <mgorny@gentoo.org>
Sat, 30 Mar 2019 16:10:37 +0000 (17:10 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 30 Mar 2019 17:42:59 +0000 (18:42 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/cryptography/cryptography-2.2.2-r1.ebuild
dev-python/cryptography/cryptography-2.3.1.ebuild
dev-python/cryptography/cryptography-2.3.ebuild
dev-python/cryptography/cryptography-2.4.2.ebuild
dev-python/cryptography/cryptography-2.5.ebuild

index 449719f769ca764a4c47c71859b6761416152ce7..a9ee41ff6db9b132f1adf44b2feddf5f86e3f16e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -33,11 +33,11 @@ RDEPEND="
        )
        libressl? ( dev-libs/libressl:0= )
        $(python_gen_cond_dep '>=dev-python/cffi-1.7:=[${PYTHON_USEDEP}]' 'python*')
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
        >=dev-python/idna-2.1[${PYTHON_USEDEP}]
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
        virtual/python-ipaddress[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index 1a58e5692ef8e51ccda14a3a1fa9f88bd3deaed3..0a3fea8750418ed5f72de11a9f2c0cddfa7f252b 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
                )
        )
        libressl? ( dev-libs/libressl:0= )
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
        >=dev-python/idna-2.1[${PYTHON_USEDEP}]
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
        virtual/python-ipaddress[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index ec123a175ee9bd5fc58a55a6f4dc52cf4dcea0bc..d7f68b52d822f511b34f8cbf58e1a3f981ee22ce 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
                )
        )
        libressl? ( dev-libs/libressl:0= )
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
        >=dev-python/idna-2.1[${PYTHON_USEDEP}]
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
        virtual/python-ipaddress[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index 4af6a76f62db8deb80b4d916e119aed734423f28..d7f68b52d822f511b34f8cbf58e1a3f981ee22ce 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -32,11 +32,11 @@ RDEPEND="
                )
        )
        libressl? ( dev-libs/libressl:0= )
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
        >=dev-python/idna-2.1[${PYTHON_USEDEP}]
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
        virtual/python-ipaddress[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}
index c6cccef62a59f6dfd86ebab4440e895bfd9df871..d75305f32e0e2c5e073bc922ea6b86d3a061af12 100644 (file)
@@ -32,11 +32,11 @@ RDEPEND="
                )
        )
        libressl? ( dev-libs/libressl:0= )
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7 pypy{,3})
        idna? ( >=dev-python/idna-2.1[${PYTHON_USEDEP}] )
        >=dev-python/asn1crypto-0.21.0[${PYTHON_USEDEP}]
        dev-python/setuptools[${PYTHON_USEDEP}]
        >=dev-python/six-1.4.1[${PYTHON_USEDEP}]
+       virtual/python-enum34[${PYTHON_USEDEP}]
        virtual/python-ipaddress[${PYTHON_USEDEP}]
        "
 DEPEND="${RDEPEND}