dev-qt/qtwayland: Use final upstream patch
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 18 Dec 2019 15:41:22 +0000 (16:41 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 18 Dec 2019 15:41:37 +0000 (16:41 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
dev-qt/qtwayland/files/qtwayland-5.14.0-fix-linuxdmabuf-build.patch [new file with mode: 0644]
dev-qt/qtwayland/qtwayland-5.14.0.ebuild

diff --git a/dev-qt/qtwayland/files/qtwayland-5.14.0-fix-linuxdmabuf-build.patch b/dev-qt/qtwayland/files/qtwayland-5.14.0-fix-linuxdmabuf-build.patch
new file mode 100644 (file)
index 0000000..7040a68
--- /dev/null
@@ -0,0 +1,31 @@
+From c2105d8b7e16cc934b886537968228f6300bf4bc Mon Sep 17 00:00:00 2001
+From: Johan Klokkhammer Helsing <johan.helsing@qt.io>
+Date: Fri, 8 Nov 2019 13:58:04 +0100
+Subject: [PATCH] Fix compilation of linuxdmabuf compositor plugin
+
+Mesa's eglext.h no longer includes eglmesaext.h, so copy over the typedefs we need.
+
+Fixes: QTBUG-79709
+Change-Id: I3190ef56e0e162636efea440dff7e760cf11fcd0
+Reviewed-by: Laszlo Agocs <laszlo.agocs@qt.io>
+---
+ .../compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h                 | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h b/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
+index 8554721e1..02b5b6f88 100644
+--- a/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
++++ b/src/hardwareintegration/compositor/linux-dmabuf-unstable-v1/linuxdmabuf.h
+@@ -58,6 +58,10 @@
+ #define DRM_FORMAT_MOD_INVALID  fourcc_mod_code(NONE, DRM_FORMAT_RESERVED)
+ #endif
++// Copied from eglmesaext.h
++typedef EGLBoolean (EGLAPIENTRYP PFNEGLBINDWAYLANDDISPLAYWL) (EGLDisplay dpy, struct wl_display *display);
++typedef EGLBoolean (EGLAPIENTRYP PFNEGLUNBINDWAYLANDDISPLAYWL) (EGLDisplay dpy, struct wl_display *display);
++
+ QT_BEGIN_NAMESPACE
+ class QWaylandCompositor;
+-- 
+2.16.3
index 921cad2b4aac94734b5e656f15c5284243bb7478..9f2838116819b47985087df98462f606078adf7b 100644 (file)
@@ -26,7 +26,9 @@ DEPEND="
 "
 RDEPEND="${DEPEND}"
 
-PATCHES=( "${FILESDIR}/${PN}-5.13.2-fix-linuxdmabuf-build.patch" )
+PATCHES=(
+       "${FILESDIR}/${P}-fix-linuxdmabuf-build.patch" # bug 699190, QTBUG-79709
+)
 
 src_prepare() {
        qt_use_disable_config libinput xkbcommon-evdev \