dev-libs/jsoncpp: Fix building docs with meson
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Dec 2019 20:22:40 +0000 (21:22 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Dec 2019 20:23:30 +0000 (21:23 +0100)
Meson does not create the 'version' file expected by the doxygen build
script.  Create it ourselves.

Closes: https://bugs.gentoo.org/703842
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-libs/jsoncpp/jsoncpp-1.9.2-r2.ebuild

index 311eab1e81277e48b7dc5d4ec697ee5cb954130f..3d6b686bd9c6afc3674de916a2685e16d533978b 100644 (file)
@@ -35,7 +35,7 @@ src_compile() {
        meson_src_compile
 
        if use doc; then
-               cp "${BUILD_DIR}"/version . || die
+               echo "${PV}" > version || die
                "${EPYTHON}" doxybuild.py --doxygen="${EPREFIX}"/usr/bin/doxygen || die
                HTML_DOCS=( dist/doxygen/jsoncpp*/. )
        fi