dev-python/chameleon: Bump to 3.6.2, py3.{7,8}
authorMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 14:21:07 +0000 (15:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Wed, 11 Mar 2020 14:21:07 +0000 (15:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/chameleon/Manifest
dev-python/chameleon/chameleon-3.6.2.ebuild [new file with mode: 0644]

index bc39bd9f5ada75e27b7a0504b81bba6a9487e1b4..80bec1b7e17ca9e88367e3b9d3e7c3fba18d3512 100644 (file)
@@ -1 +1,2 @@
 DIST Chameleon-2.25.tar.gz 193965 BLAKE2B a6ae7768c52807a82229d75fc044116a77df5ae3032a98e44558a1d2b3ee2f427f3291b7c2895639050ea1e9fda0e6868ca7b8299cbbf1d5e1b0714af0d835c0 SHA512 b2ffc05c6ab5268757ae6a93a0579d8031dfe7e09882f0f3f0b9a25677ecf896af99a8e7cf6bec98648e9c8526365e7e517bc174d36137734968d80f3f14a05d
+DIST Chameleon-3.6.2.tar.gz 121518 BLAKE2B 1a49b671a2ec437570581489670a86f4f07ec512a5902ad128806ed9cd3bc813be17b806d942a8a8ed30ec9a48e7f20116a691a5d1c0e3f7d98f8781de470b3b SHA512 0bdc1314cbb37f462de640b89f0e7319025938253df34303c033c8cc903f94f183bb33fc99afdda9ff4cf500c78778df6f5f1f72c0c1607014d6a38117d269e4
diff --git a/dev-python/chameleon/chameleon-3.6.2.ebuild b/dev-python/chameleon/chameleon-3.6.2.ebuild
new file mode 100644 (file)
index 0000000..78effbc
--- /dev/null
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P^}
+DESCRIPTION="Fast HTML/XML template compiler for Python"
+HOMEPAGE="https://github.com/malthe/chameleon
+       https://pypi.org/project/Chameleon/"
+SRC_URI="mirror://pypi/${MY_P::1}/${PN^}/${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="repoze"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests setup.py