sci-libs/ViSP: Remove support for non-existent deps
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 18:09:10 +0000 (20:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 18:22:14 +0000 (20:22 +0200)
sci-libs/ViSP/ViSP-3.0.1.ebuild
sci-libs/ViSP/ViSP-3.1.0.ebuild

index 390e20cb18a2c36146a12ea305f715806e9294a6..35fbfb4321bfd9e013fa7dfc5f7ca1a36dc6644f 100644 (file)
@@ -14,7 +14,7 @@ SLOT="0/3"
 KEYWORDS="~amd64 ~arm"
 IUSE="
        +coin demos +dmtx doc examples ffmpeg gsl ieee1394 jpeg lapack motif ogre
-       ois opencv png qt4 test tutorials usb v4l X xml +zbar zlib
+       ois opencv png test tutorials usb v4l X xml +zbar zlib
        cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3
 "
 
@@ -26,11 +26,10 @@ RDEPEND="
        ieee1394? ( media-libs/libdc1394 )
        jpeg? ( virtual/jpeg:0 )
        lapack? ( virtual/lapack )
-       !qt4? ( motif? ( media-libs/SoXt ) )
+       motif? ( media-libs/SoXt )
        ogre? ( dev-games/ogre[ois?] dev-libs/boost:=[threads] )
-       opencv? ( media-libs/opencv:= qt4? ( media-libs/opencv[-qt5(-)] ) )
+       opencv? ( media-libs/opencv:= )
        png? ( media-libs/libpng:0= )
-       qt4? ( media-libs/SoQt dev-qt/qtgui:4 )
        usb? ( virtual/libusb:1 )
        v4l? ( media-libs/libv4l )
        X? ( x11-libs/libX11 )
@@ -48,7 +47,6 @@ RDEPEND="${RDEPEND}
 REQUIRED_USE="
        ffmpeg? ( opencv )
        ois? ( ogre )
-       qt4? ( coin )
        motif? ( coin )
 "
 
@@ -73,8 +71,8 @@ src_configure() {
                "-DUSE_OGRE=$(usex ogre ON OFF)"
                "-DUSE_OIS=$(usex ois ON OFF)"
                "-DUSE_OPENCV=$(usex opencv ON OFF)"
-               "-DUSE_SOQT=$(usex qt4 ON OFF)"
-               "-DUSE_SOXT=$(usex motif "$(usex qt4 OFF ON)" OFF)"
+               "-DUSE_SOQT=OFF"
+               "-DUSE_SOXT=$(usex motif ON OFF)"
                "-DUSE_V4L2=$(usex v4l ON OFF)"
                "-DUSE_X11=$(usex X ON OFF)"
                "-DUSE_XML2=$(usex xml ON OFF)"
index 07dfbbd910586c1f5543c49183adcf87929b1e5a..354edc0a62bd75197915e514e4f8835c4666461d 100644 (file)
@@ -14,7 +14,7 @@ SLOT="0/3.1"
 KEYWORDS="~amd64 ~arm"
 IUSE="
        +coin demos +dmtx doc examples gsl ieee1394 jpeg lapack motif ogre
-       ois opencv png qt4 test tutorials usb v4l X xml +zbar zlib
+       ois opencv png test tutorials usb v4l X xml +zbar zlib
        cpu_flags_x86_sse2 cpu_flags_x86_sse3 cpu_flags_x86_ssse3
 "
 
@@ -25,11 +25,10 @@ RDEPEND="
        ieee1394? ( media-libs/libdc1394 )
        jpeg? ( virtual/jpeg:0 )
        lapack? ( virtual/lapack )
-       !qt4? ( motif? ( media-libs/SoXt ) )
+       motif? ( media-libs/SoXt )
        ogre? ( dev-games/ogre[ois?] dev-libs/boost:=[threads] )
-       opencv? ( media-libs/opencv:= qt4? ( media-libs/opencv[-qt5(-)] ) )
+       opencv? ( media-libs/opencv:= )
        png? ( media-libs/libpng:0= )
-       qt4? ( media-libs/SoQt dev-qt/qtgui:4 )
        usb? ( virtual/libusb:1 )
        v4l? ( media-libs/libv4l )
        X? ( x11-libs/libX11 )
@@ -46,7 +45,6 @@ RDEPEND="${RDEPEND}
        demos? ( sci-misc/ViSP-images )"
 REQUIRED_USE="
        ois? ( ogre )
-       qt4? ( coin )
        motif? ( coin )
 "
 
@@ -70,8 +68,8 @@ src_configure() {
                "-DUSE_OGRE=$(usex ogre ON OFF)"
                "-DUSE_OIS=$(usex ois ON OFF)"
                "-DUSE_OPENCV=$(usex opencv ON OFF)"
-               "-DUSE_SOQT=$(usex qt4 ON OFF)"
-               "-DUSE_SOXT=$(usex motif "$(usex qt4 OFF ON)" OFF)"
+               "-DUSE_SOQT=OFF"
+               "-DUSE_SOXT=$(usex motif ON OFF)"
                "-DUSE_V4L2=$(usex v4l ON OFF)"
                "-DUSE_X11=$(usex X ON OFF)"
                "-DUSE_XML2=$(usex xml ON OFF)"