dev-python/websockify: 0.9.0 bump
authorMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 16:59:54 +0000 (11:59 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 24 Mar 2020 17:11:25 +0000 (12:11 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
dev-python/websockify/Manifest
dev-python/websockify/metadata.xml
dev-python/websockify/websockify-0.9.0.ebuild [new file with mode: 0644]

index 09fb575383ce5a9e5bb70d00fdf8a4f56413c951..3ab9b605641cce0869ab442fd0166597d2c9bc6a 100644 (file)
@@ -1 +1,2 @@
 DIST websockify-0.8.0.zip 319105 BLAKE2B 5c9a0e5f32239b35b5f41d5dd2b46b215cad6800e5752e8d9fa0c20fe77df2ae756cc74a527b50f545497abdc621ee402e02a9d2a788630a2cbfdeecb7b494df SHA512 625cecbf37149c82edd2ebb9cd1f1a20a35415f7c7696ebe88b2e86563a170573959f9ede2c7a1db82ace9edddfb9d2da6e2e20d29fd916ae238235880d9a943
+DIST websockify-0.9.0.tar.gz 58493 BLAKE2B 622a36979ec083dd3ea747b43cd8fec0916f9eb6f1a2b8f9b7acabd38f41aec839b2101c5261fdf2474bc40ebbbef61c9ba51d2e57f749f1e1a1c46879fb5d65 SHA512 d2251f653a40dc6dca0e5541845565d968c60be96a20a9b70b0305c4b7578f7fe205d4b98a94bb77d7c9383a396833af90fe92a6ade7e1a6f2d9bf8513d372c8
index a9a4016cc3cb38b8e4e87f7f470bb59d56a1a280..67a4c5863e2b122a424c721596d188b067ce6c70 100644 (file)
@@ -9,9 +9,6 @@
     <email>python@gentoo.org</email>
     <name>Python</name>
   </maintainer>
-  <longdescription lang="en">
-    WebSockets support for any application/server
-  </longdescription>
   <upstream>
     <remote-id type="github">kanaka/websockify</remote-id>
   </upstream>
diff --git a/dev-python/websockify/websockify-0.9.0.ebuild b/dev-python/websockify/websockify-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..48eee9f
--- /dev/null
@@ -0,0 +1,18 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit distutils-r1
+
+SRC_URI="https://github.com/kanaka/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="WebSockets support for any application/server"
+HOMEPAGE="https://github.com/kanaka/websockify"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/numpy[${PYTHON_USEDEP}]"