dev-python/jikanpy-3.4.2: version bump
authorPiotr Karbowski <slashbeast@gentoo.org>
Sun, 15 Dec 2019 21:29:29 +0000 (22:29 +0100)
committerPiotr Karbowski <slashbeast@gentoo.org>
Sun, 15 Dec 2019 21:40:17 +0000 (22:40 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
dev-python/jikanpy/Manifest
dev-python/jikanpy/jikanpy-3.4.2.ebuild [new file with mode: 0644]

index 3bceed938fcd789637f5916021b330487096d07f..39b3bdca948f4fbdaa657bbd635356e69050bbc3 100644 (file)
@@ -1 +1,2 @@
 DIST jikanpy-3.4.1.tar.gz 13653 BLAKE2B 9e9e5b9f6f5fc28a7ce98a6ab79254aafeb7d2a77e0bdbf7790b3c9a19e41caca1002d53a2effdafba13db1271546ae104cf9521afcf4fe2b02effd2c4e38163 SHA512 fd5703f86b439185f46e563cd32ec75e176138b7128f3c1c80dddccf569a066da7e493d6b48979a69ec5f55c0b2bf1396676d4da2529ae16db106b6cd6170c5e
+DIST jikanpy-3.4.2.tar.gz 14132 BLAKE2B 4a06cd0ac37968c26cf062c7aa7b42a23795f372a814641d373097e67c0958ea2e640b9945883552c6997285fb3d19991482ed4872c5c74097940121edddca4d SHA512 cff23a20a331da55036875c2ea34e3bcf7c28592b625bb9c3fc453969db2f232cd30841757ec8d75807f323a2caa0f591f91e71547b29d07694560462c561d30
diff --git a/dev-python/jikanpy/jikanpy-3.4.2.ebuild b/dev-python/jikanpy/jikanpy-3.4.2.ebuild
new file mode 100644 (file)
index 0000000..52e861d
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for jikan.moe API."
+HOMEPAGE="https://pypi.org/project/jikanpy/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       dev-python/aiohttp[${PYTHON_USEDEP}]
+       dev-python/requests[${PYTHON_USEDEP}]
+"