dev-python/flask-themes: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:11:58 +0000 (10:11 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 27 Mar 2020 09:16:23 +0000 (10:16 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/flask-themes/Manifest
dev-python/flask-themes/files/fixtests.patch [deleted file]
dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild [deleted file]

index d4c057b1911b0a48ec0721942cb47e8636efd59a..36aa8b188ef228bd807afc67ec42d21cfcf4beb6 100644 (file)
@@ -1,2 +1 @@
-DIST Flask-Themes-0.1.3.tar.gz 9723 BLAKE2B c141363ddcd4d0fa510845fcece4aedf831fed6c1ffac8a6b625265165bce77193ba6240bf5acc9ba990b914d88dabccb76871ac62eff629886348c3b4c7a382 SHA512 baf609b8b08446dda5b5d6d39bc0a2e7406f9270d70924c795243384be8967c82f82adcebe5e060352a0c33b763d600eeb5600d3116c10bdbbb3ceddfadf764a
 DIST flask-themes-0.1.3_p20180112.tar.gz 35526 BLAKE2B 71c606b8d0f2d2edf65594904c2ae11ca9236bb9386452592dae347293803e6c613cb2223e92e58f4b8a4e3b20365b17520889d173cd0ceb2255f849ea216ee8 SHA512 e7adbf309b07690906700608963f2cc8dd0fffb3edb061a10dae3b9d40f9ba6c6a56661ae47d34d808798d4ed168376c32642b47cbbab186d587bbedf1eba722
diff --git a/dev-python/flask-themes/files/fixtests.patch b/dev-python/flask-themes/files/fixtests.patch
deleted file mode 100644 (file)
index 014508e..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
-diff -ur Flask-Themes-0.1.3.orig/tests/test-themes.py Flask-Themes-0.1.3/tests/test-themes.py
---- tests/test-themes.py       2011-07-14 06:36:33.000000000 +0800
-+++ tests/test-themes.py       2013-06-10 18:20:25.901480529 +0800
-@@ -129,8 +129,8 @@
-         
-         with app.test_request_context('/'):
-             assert template_exists('hello.html')
--            assert template_exists('_themes/cool/hello.html')
--            assert not template_exists('_themes/plain/hello.html')
-+            assert template_exists('cool/hello.html')
-+            assert not template_exists('themes/plain/hello.html')
-     
-     def test_loader(self):
-         app = Flask(__name__)
-@@ -140,7 +140,7 @@
-         with app.test_request_context('/'):
-             if USING_BLUEPRINTS:
-                 src = themes_blueprint.jinja_loader.get_source(
--                    app.jinja_env, '_themes/cool/hello.html'
-+                    app.jinja_env, 'cool/hello.html'
-                 )
-             else:
-                 src = themes_mod.jinja_loader.get_source(
diff --git a/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild b/dev-python/flask-themes/flask-themes-0.1.3-r1.ebuild
deleted file mode 100644 (file)
index 454357b..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-MY_PN="Flask-Themes"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Infrastructure for theming support in Flask applications"
-HOMEPAGE="https://pythonhosted.org/Flask-Themes/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-# suite fails miserably under py3. Cannot even find upstream repo to file. pypi.org does NOT help
-RESTRICT="test"
-
-RDEPEND=">=dev-python/flask-0.6[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=( "${FILESDIR}"/fixtests.patch )