Snapshot updated
authorLuca Barbato <lu_zero@gentoo.org>
Mon, 4 Dec 2006 00:27:25 +0000 (00:27 +0000)
committerLuca Barbato <lu_zero@gentoo.org>
Mon, 4 Dec 2006 00:27:25 +0000 (00:27 +0000)
Package-Manager: portage-2.1.2_rc2

sys-libs/newlib/ChangeLog
sys-libs/newlib/files/digest-newlib-20061203 [new file with mode: 0644]
sys-libs/newlib/newlib-20061203.ebuild [new file with mode: 0644]

index ee3c69b7102bedb01a08518ee94da7e3d7014ba2..ff6404d264ed9579978c5588d05566765af612fd 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for sys-libs/newlib
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.2 2006/11/13 22:21:37 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/ChangeLog,v 1.3 2006/12/04 00:27:25 lu_zero Exp $
+
+*newlib-20061203 (04 Dec 2006)
+
+  04 Dec 2006; Luca Barbato <lu_zero@gentoo.org> -newlib-20061113.ebuild,
+  +newlib-20061203.ebuild:
+  Updated snapshot, fixes for SPU support
 
 *newlib-20061113 (13 Nov 2006)
 
diff --git a/sys-libs/newlib/files/digest-newlib-20061203 b/sys-libs/newlib/files/digest-newlib-20061203
new file mode 100644 (file)
index 0000000..0ccab26
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 3410a58ad88025a837c1d4abead01123 newlib-20061203.tar.bz2 6664575
+RMD160 ad4b1495e4fd7e94060a63b27719fb18d3b3082d newlib-20061203.tar.bz2 6664575
+SHA256 900fd7d076367f36594c87f422513dbf7b46045a27f20c25954807af3705d320 newlib-20061203.tar.bz2 6664575
diff --git a/sys-libs/newlib/newlib-20061203.ebuild b/sys-libs/newlib/newlib-20061203.ebuild
new file mode 100644 (file)
index 0000000..a173b38
--- /dev/null
@@ -0,0 +1,75 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-libs/newlib/newlib-20061203.ebuild,v 1.1 2006/12/04 00:27:25 lu_zero Exp $
+
+inherit eutils flag-o-matic
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+               if [[ ${CATEGORY/cross-} != ${CATEGORY} ]] ; then
+                       export CTARGET=${CATEGORY/cross-}
+               fi
+fi
+
+# Handle the case where we want newlib on glibc ...
+if [[ ${CTARGET} == ${CHOST} ]] && [[ ${CHOST} != *-newlib ]] ; then
+       export CTARGET=${CHOST%%-*}-pc-linux-newlib
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="http://sourceware.org/newlib/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+[[ ${CTARGET} != ${CHOST} ]] \
+       && SLOT="${CTARGET}" \
+       || SLOT="0"
+KEYWORDS="-* ~ppc64 ~ppc"
+IUSE="nls threads unicode multilib"
+RESTRICT="strip"
+
+DEPEND=""
+RDEPEND=""
+
+NEWLIBBUILD="${WORKDIR}/build"
+S="${WORKDIR}/newlib"
+
+src_unpack() {
+       unpack ${A}
+       mkdir -p "${NEWLIBBUILD}"
+}
+
+src_compile() {
+       # we should fix this ...
+       unset LDFLAGS
+       CHOST=${CTARGET} strip-unsupported-flags
+
+       local myconf=""
+       # hardwired to avoid breakages
+       [[ ${CTARGET} == *-softfloat-* ]] \
+               && myconf="--disable-newlib-hw-fp" \
+               || myconf="--enable-newlib-hw-fp"
+       [[ ${CTARGET} == "spu" ]] \
+               && myconf="${myconf} --disable-threads" \
+               || myconf="${myconf} $(use_enable threads)"
+
+       cd "${NEWLIBBUILD}"
+
+       ECONF_SOURCE=${S} \
+       econf \
+               $(use_enable unicode newlib-mb) \
+               $(use_enable nls) \
+               $(use_enable multilib) \
+               ${myconf} \
+               || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       cd "${NEWLIBBUILD}"
+       emake -j1 DESTDIR="${D}" install
+       env -uRESTRICT CHOST=${CTARGET} prepallstrip
+       # minor hack to keep things clean
+       rm -fR "${D}"/usr/info
+}