anacron: EAPI: update to 5
authorMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:26:12 +0000 (03:26 -0400)
committerMike Frysinger <vapier@gentoo.org>
Mon, 10 Aug 2015 07:59:46 +0000 (03:59 -0400)
This allows us to show the elog messages only once on initial install.

sys-process/anacron/anacron-2.3-r3.ebuild

index 22fd43f6b8dd14466882731331aef35d1dc11b7d..d68bb7913a6ea4863b6a114ceb0731b4fbeb5aae 100644 (file)
@@ -2,6 +2,8 @@
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
+EAPI="5"
+
 inherit eutils
 
 DESCRIPTION="a periodic command scheduler"
@@ -17,17 +19,11 @@ DEPEND="sys-process/cronbase"
 RDEPEND="${RDEPEND}
        virtual/mta"
 
-src_unpack() {
-       unpack ${A}
-       cd "${S}"
+src_prepare() {
        epatch "${FILESDIR}"/${P}-compile-fix-from-debian.patch
        sed -i "s:^CFLAGS =:CFLAGS = $CFLAGS:" Makefile
 }
 
-src_compile() {
-       emake || die
-}
-
 src_install() {
        #this does not work if the directory exists already
        diropts -m0750 -o root -g cron
@@ -47,14 +43,16 @@ src_install() {
 }
 
 pkg_postinst() {
-       elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
-       elog "at some early morning hour).  This will make sure that jobs are run"
-       elog "when the systems is left running for a night."
-       echo
-       elog "Update /etc/anacrontab to include what you want anacron to run."
-
-       echo
-       elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
-       elog "found online at:"
-       elog "    http://www.gentoo.org/doc/en/cron-guide.xml"
+       if [[ -z ${REPLACING_VERSIONS} ]] ; then
+               elog "Schedule the command \"anacron -s\" as a daily cron-job (preferably"
+               elog "at some early morning hour).  This will make sure that jobs are run"
+               elog "when the systems is left running for a night."
+               echo
+               elog "Update /etc/anacrontab to include what you want anacron to run."
+
+               echo
+               elog "You may wish to read the Gentoo Linux Cron Guide, which can be"
+               elog "found online at:"
+               elog "    http://www.gentoo.org/doc/en/cron-guide.xml"
+       fi
 }