dev-vcs/gitolite: Drop unmaintained -9999
authorMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 19:56:10 +0000 (20:56 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 15 Dec 2019 20:06:11 +0000 (21:06 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-vcs/gitolite/gitolite-9999.ebuild [deleted file]

diff --git a/dev-vcs/gitolite/gitolite-9999.ebuild b/dev-vcs/gitolite/gitolite-9999.ebuild
deleted file mode 100644 (file)
index 928bbe8..0000000
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-[[ ${PV} == *9999 ]] && SCM="git-2"
-EGIT_REPO_URI="https://github.com/sitaramc/${PN}.git"
-EGIT_MASTER=master
-
-inherit perl-module user versionator ${SCM}
-
-DESCRIPTION="Highly flexible server for git directory version tracker"
-HOMEPAGE="https://github.com/sitaramc/gitolite"
-if [[ ${PV} != *9999 ]]; then
-       SRC_URI="https://github.com/sitaramc/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~arm ~x86"
-else
-       SRC_URI=""
-       KEYWORDS=""
-fi
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="selinux tools vim-syntax"
-
-DEPEND="dev-lang/perl
-       virtual/perl-File-Path
-       virtual/perl-File-Temp
-       >=dev-vcs/git-1.6.6"
-RDEPEND="${DEPEND}
-       !dev-vcs/gitolite-gentoo
-       selinux? ( sec-policy/selinux-gitosis )
-       vim-syntax? ( app-vim/gitolite-syntax )
-       dev-perl/JSON"
-
-pkg_setup() {
-       enewgroup git
-       enewuser git -1 /bin/sh /var/lib/gitolite git
-}
-
-src_prepare() {
-       echo $PF > src/VERSION
-}
-
-src_install() {
-       local uexec=/usr/libexec/${PN}
-
-       rm -rf src/lib/Gitolite/Test{,.pm}
-       insinto $VENDOR_LIB
-       doins -r src/lib/Gitolite
-
-       dodoc README.markdown CHANGELOG
-       # These are meant by upstream as examples, you are strongly recommended to
-       # customize them for your needs.
-       dodoc contrib/utils/ipa_groups.pl contrib/utils/ldap_groups.sh
-
-       insopts -m0755
-       insinto $uexec
-       doins -r src/{commands,syntactic-sugar,triggers,VREF}/
-       doins -r contrib/{commands,triggers,hooks}
-
-       insopts -m0644
-       doins src/VERSION
-
-       exeinto $uexec
-       doexe src/gitolite{,-shell}
-
-       dodir /usr/bin
-       for bin in gitolite{,-shell}; do
-               dosym /usr/libexec/${PN}/${bin} /usr/bin/${bin}
-       done
-
-       if use tools; then
-               dobin check-g2-compat convert-gitosis-conf
-               dobin contrib/utils/rc-format-v3.4
-       fi
-
-       keepdir /var/lib/gitolite
-       fowners git:git /var/lib/gitolite
-       fperms 750 /var/lib/gitolite
-
-       fperms 0644 ${uexec}/VREF/MERGE-CHECK # It's meant as example only
-}
-
-pkg_postinst() {
-       if [[ "$(get_major_version $REPLACING_VERSIONS)" == "2" ]]; then
-               ewarn
-               elog "***NOTE*** This is a major upgrade and will likely break your existing gitolite-2.x setup!"
-               elog "Please read http://gitolite.com/gitolite/migr/index.html first!"
-       fi
-
-       # bug 352291
-       ewarn
-       elog "Please make sure that your 'git' user has the correct homedir (/var/lib/gitolite)."
-       elog "Especially if you're migrating from gitosis."
-       ewarn
-}