version bump (bug #546456)
authorMichael Sterrett <mr_bones_@gentoo.org>
Thu, 10 Dec 2015 02:28:22 +0000 (21:28 -0500)
committerMichael Sterrett <mr_bones_@gentoo.org>
Thu, 10 Dec 2015 02:28:22 +0000 (21:28 -0500)
Package-Manager: portage-2.2.24

games-strategy/freecol/Manifest
games-strategy/freecol/files/freecol-0.11.5-gentoo.patch [new file with mode: 0644]
games-strategy/freecol/freecol-0.11.5.ebuild [new file with mode: 0644]

index 4378b01ebb50b0eff26ecc5eb335a94527c71e8b..ac0c8741b53bb1ecd7af9d86a2241455a03dc25e 100644 (file)
@@ -1 +1,2 @@
 DIST freecol-0.10.7-src.zip 46805547 SHA256 6909fc4e98dd765863b860d0fe16c5b75232d6fd4ef0ddea6e6de50cb06813fc SHA512 39bb8d9cc4566fb63c044552ef8bb698d06cb0a8baad85145288c5a435022efef5af822d6f779ebeb43d943916625320558dd118412e1bcaca0b2a0fa2b859d2 WHIRLPOOL 0fb908668807d3256ffb37e3c97d4ad0421c6f809e7e836f187f0d87af16c5953178165dabd799551fcf261d02f8671f4f360c4b851a6be77c47c556e86f67aa
+DIST freecol-0.11.5-src.zip 45280324 SHA256 99b31077fb3d7bfab44fcb900e0ea828a1dedf44fa814e05e166f240a68a5078 SHA512 1059c3b5c87c0f5ae07a99aaab1af2f73c7767a536aa2cff1b6c518b53d9ef6cb75713b4aeb601ab02bf946dcf451d01775b27cf82c457c0b9869e4cfeb55965 WHIRLPOOL 859c5097db4db88642fdfe0189bb731f47e7fe5118e943958698c351b21b6e0762a106b9541a8554633f770c7c2a0d4b57a8b7b26584e96be1277ec887721d67
diff --git a/games-strategy/freecol/files/freecol-0.11.5-gentoo.patch b/games-strategy/freecol/files/freecol-0.11.5-gentoo.patch
new file mode 100644 (file)
index 0000000..c087193
--- /dev/null
@@ -0,0 +1,27 @@
+--- build.xml.orig     2015-12-09 21:10:08.272361404 -0500
++++ build.xml  2015-12-09 21:11:26.189663216 -0500
+@@ -36,12 +36,11 @@
+     <path id="libraries.classpath">
+         <!-- MigLayout manager -->
+-        <pathelement location="${basedir}/${miglayout-swing.jar}"/>
+-        <pathelement location="${basedir}/${miglayout-core.jar}"/>
++        <pathelement location="${miglayout.jar}"/>
+         <!-- Command line processor -->
+-        <pathelement location="${basedir}/${cli.jar}"/>
++        <pathelement location="${cli.jar}"/>
+         <!-- Cortado Video Applet -->
+-        <pathelement location="${basedir}/${cortado.jar}"/>
++        <pathelement location="${cortado.jar}"/>
+         <!-- JOgg/JOrbis libraries -->
+         <pathelement location="${basedir}/jars/jogg-0.0.17.jar"/>
+         <pathelement location="${basedir}/jars/jorbis-0.0.17.jar"/>
+@@ -162,7 +161,7 @@
+     <target name="manifest" depends="git-revision"
+             description="Creates the Manifest file.">
+-        <manifestclasspath property="jar.classpath"
++        <manifestclasspath maxParentLevels="50" property="jar.classpath"
+                            jarfile="Freecol.jar">
+             <classpath refid="libraries.classpath" />
+         </manifestclasspath>
diff --git a/games-strategy/freecol/freecol-0.11.5.ebuild b/games-strategy/freecol/freecol-0.11.5.ebuild
new file mode 100644 (file)
index 0000000..e89e0ac
--- /dev/null
@@ -0,0 +1,80 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/freecol/freecol-0.10.7.ebuild,v 1.3 2015/02/25 15:52:06 ago Exp $
+
+EAPI=5
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="An open source clone of the game Colonization"
+HOMEPAGE="http://www.freecol.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}-src.zip"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEP="dev-java/jsr173
+       dev-java/wstx:3.2
+       dev-java/commons-cli:1
+       dev-java/cortado
+       dev-java/miglayout"
+DEPEND=">=virtual/jdk-1.7
+       app-arch/unzip
+       ${COMMON_DEP}"
+RDEPEND=">=virtual/jre-1.7
+       ${COMMON_DEP}"
+
+S=${WORKDIR}/${PN}
+
+java_prepare() {
+       # jorbis isn't in portage yet
+       rm jars/{commons-cli-1.1,cortado-0.6.0,miglayout-core-4.2,miglayout-swing-4.2}.jar || die
+       epatch "${FILESDIR}"/${P}-gentoo.patch
+}
+
+src_prepare() {
+       java-pkg-2_src_prepare
+}
+
+src_configure() {
+       java-ant-2_src_configure
+}
+
+src_compile() {
+       EANT_BUILD_TARGET=package
+       EANT_EXTRA_ARGS="
+               -Dstax.jar=$(java-pkg_getjars jsr173)
+               -Dwoodstox.jar=$(java-pkg_getjars wstx-3.2)
+               -Dcli.jar=$(java-pkg_getjars commons-cli-1)
+               -Dmiglayout.jar=$(java-pkg_getjars miglayout)
+               -Dcortado.jar=$(java-pkg_getjars cortado)
+       "
+       java-pkg-2_src_compile
+}
+
+src_install() {
+       java-pkg_jarinto "${GAMES_DATADIR}"/${PN}
+       java-pkg_dojar FreeCol.jar
+       java-pkg_dolauncher ${PN} \
+               -into "${GAMES_PREFIX}" \
+               --pwd "${GAMES_DATADIR}"/${PN} \
+               --jar FreeCol.jar \
+               --java_args -Xmx512M
+       insinto "${GAMES_DATADIR}"/${PN}
+       doins -r data schema splash.jpg
+       doicon data/${PN}.png
+       make_desktop_entry ${PN} FreeCol
+       dodoc README
+       prepgamesdirs
+}
+
+pkg_setup() {
+       games_pkg_setup
+       java-pkg-2_pkg_setup
+}
+
+pkg_preinst() {
+       games_pkg_preinst
+       java-pkg-2_pkg_preinst
+}