dev-python/configclass: Enable tests
authorMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 15:56:45 +0000 (17:56 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 20 Apr 2020 16:18:56 +0000 (18:18 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/configclass/Manifest
dev-python/configclass/configclass-0.1.0.ebuild

index 0677310f6e84dce6af1c913dbf70ddf2b1165ca3..cfb19dadee05fa1b7a907ab94e557f223d41b338 100644 (file)
@@ -1 +1 @@
-DIST configclass-0.1.0.tar.gz 3246 BLAKE2B e97ea98e495dc920d50e7240eed4d9182829b664baac0e8712b5551703f730f7052228d693a60784435fbc839639fef9e5c29caef2f8fa26827016aead182a8e SHA512 d3a83c742916a9d345a3e8b2fb29d8742cff67a110f9bbaaee6e04fc1134faa6eee13f7344a95f133107afcdfccd394f6a3b5fc516b21dbfd7ac38a5bed00d34
+DIST configclass-0.1.0.gh.tar.gz 4585 BLAKE2B 39f53c1b80ed494764be0e307c452b7e8675b63e49d3640346e55461eb482e2840c85f7bfd2030129f46b5022cea21365377a794e99d6a016f35db37e14af6db SHA512 5caaa9d365e4c84a328acd853661511451d74fbe2e0fde3d96a4313131af26c4088f3a3fa6cce4bd520eb85de41e59ab512e4d99d148d26a945ee2c5fa366b6b
index e962c072852ee1874a2138fcb392625c744dcbf0..83a1e2f50bc9a7e68badf6c36a27856d6a7e42f5 100644 (file)
@@ -1,19 +1,22 @@
 # Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=5
+EAPI=7
 PYTHON_COMPAT=( python3_6 )
 
 inherit distutils-r1
 
 DESCRIPTION="A Python to class to hold configuration values"
 HOMEPAGE="https://github.com/schettino72/configclass/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="
+       https://github.com/schettino72/configclass/archive/${PV}.tar.gz
+               -> ${P}.gh.tar.gz"
 
 LICENSE="MIT"
 SLOT="0"
 KEYWORDS="amd64 ~x86"
 IUSE=""
 
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
 RDEPEND=">=dev-python/mergedict-0.2.0[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest