net-voip/telepathy-haze: Flatten twisted dep
authorMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 17:29:43 +0000 (18:29 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 26 Mar 2020 17:36:00 +0000 (18:36 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-voip/telepathy-haze/telepathy-haze-0.8.0-r2.ebuild

index 124ede37e15734a0be04b4174c8d40c31cfd16d3..3a90c52fe393dd06a62131fe196aaf08302e584d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -30,10 +30,7 @@ DEPEND="${RDEPEND}
        virtual/pkgconfig
        test? (
                dev-python/pygobject:2
-               || (
-                       $(python_gen_any_dep 'dev-python/twisted[${PYTHON_USEDEP}]')
-                       $(python_gen_any_dep 'dev-python/twisted-words[${PYTHON_USEDEP}]')
-               )
+               $(python_gen_any_dep 'dev-python/twisted[${PYTHON_USEDEP}]')
        )
 "
 
@@ -48,8 +45,7 @@ PATCHES=(
 
 python_check_deps() {
        if use test ; then
-               has_version "dev-python/twisted[${PYTHON_USEDEP}]" \
-                       || has_version "dev-python/twisted-words[${PYTHON_USEDEP}]"
+               has_version "dev-python/twisted[${PYTHON_USEDEP}]"
        fi
 }