dev-python/pillow: remove old
authorVirgil Dupras <vdupras@gentoo.org>
Wed, 5 Jun 2019 11:57:56 +0000 (07:57 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Wed, 5 Jun 2019 11:57:56 +0000 (07:57 -0400)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

dev-python/pillow/Manifest
dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch [deleted file]
dev-python/pillow/pillow-5.2.0.ebuild [deleted file]

index 8ba4bd6a56cbf28db6fb7269ae8e0e1cda469ab2..7cabdc3d8635061910fd6fd43098d9085ee45d53 100644 (file)
@@ -1,4 +1,3 @@
 DIST Pillow-3.4.2.zip 11042238 BLAKE2B 334af6eeadb3203b51572eca6ad9c196f3eeac14da0f1aedc351db692b33d413fdf5bc5c8564d2f53c324d9485dbdbda664b75a570b779e24f238c21829b4a39 SHA512 5e05206db5bc1b4177384f7e91ee79015c6e1bbdc7c31c997da054391b9b5ec7c1ebdec258a33f598986533894f3324b03d0b4b385b94e72a0517a3437553b39
-DIST Pillow-5.2.0.tar.gz 14499068 BLAKE2B 7111eb8e2911cc197b66bbc06a13459484e2c4a1f5037e4bcf702ea350763b2b758cbeef9749aeb29f1ab64d33081131f7e46a3fbb33fee48e70660f8f75eddb SHA512 2f19512d0573bd4696a5b4d54ff21473492f92705d33bd0994ccd085028d209bfb0031e2b95947c1e8fc9d0b0956cdf1f705c1fbaff39390791cac1708bff22c
 DIST pillow-5.4.1.tar.gz 15799745 BLAKE2B d9e3851a80a1f94d7292852b9ab806d9a26870795f499bb109a440e64c07112055a4cd382688b977f3c3ae76ed3d6fd38460afff594f964338afa668d288e4de SHA512 20b75ab50df7e9545c76d66ad585922d1f86fbcf8df9d2566882ab8929c3122573b9ec622766523ec46f5e7a98740cc78ff192e3e8f08ab0b77a7f2b033a7f62
 DIST pillow-6.0.0.tar.gz 29205509 BLAKE2B 83e2d1abeea468b7bf344ea5003940b14d6c69649e02a954c0b3810fc5d77288c361fb40747171176d29843848d802b783a2b0c0de15476462f17f15552298fa SHA512 c5fbe1432d576fe4a70a15fa7a70a446ccbcb247fbd4c3605917fa26a6345eb9319c0153dba7637d521c358963f2f06f525219aa1af1502da2565d54dceef4c5
diff --git a/dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch b/dev-python/pillow/files/pillow-5.2.0-fix-lib-paths.patch
deleted file mode 100644 (file)
index b736818..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
-diff --git a/setup.py b/setup.py
-index 761d552c..c4a55092 100755
---- a/setup.py
-+++ b/setup.py
-@@ -435,6 +435,11 @@ class pil_build_ext(build_ext):
-                 _add_directory(include_dirs,
-                                os.path.join(best_path, 'include'))
-+        # The logic above fails in many cases (such as pypy builds) and we fix
-+        # it here by making sure we look in standard places first.
-+        library_dirs = ['/usr/lib64', '/usr/lib'] + library_dirs
-+        include_dirs = ['/usr/include'] + include_dirs
-+
-         #
-         # insert new dirs *before* default libs, to avoid conflicts
-         # between Python PYD stub libs and real libraries
diff --git a/dev-python/pillow/pillow-5.2.0.ebuild b/dev-python/pillow/pillow-5.2.0.ebuild
deleted file mode 100644 (file)
index 3eb0933..0000000
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
-PYTHON_REQ_USE='tk?,threads(+)'
-
-inherit distutils-r1 virtualx
-
-MY_PN=Pillow
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="Python Imaging Library (fork)"
-HOMEPAGE="https://python-pillow.org/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="HPND"
-SLOT="0"
-KEYWORDS="amd64 arm ~arm64 ~hppa ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples imagequant jpeg jpeg2k lcms test tiff tk truetype webp zlib"
-
-REQUIRED_USE="test? ( jpeg tiff )"
-
-RDEPEND="
-       dev-python/olefile[${PYTHON_USEDEP}]
-       imagequant? ( media-gfx/libimagequant:0 )
-       jpeg? ( virtual/jpeg:0 )
-       jpeg2k? ( media-libs/openjpeg:2= )
-       lcms? ( media-libs/lcms:2= )
-       tiff? ( media-libs/tiff:0=[jpeg,zlib] )
-       truetype? ( media-libs/freetype:2= )
-       webp? ( media-libs/libwebp:0= )
-       zlib? ( sys-libs/zlib:0= )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? (
-               dev-python/sphinx[${PYTHON_USEDEP}]
-               dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
-       )
-       test? (
-               <dev-python/pytest-3.10[${PYTHON_USEDEP}]
-               media-gfx/imagemagick[png]
-       )
-"
-
-S="${WORKDIR}/${MY_P}"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-5.2.0-fix-lib-paths.patch"
-)
-
-python_configure_all() {
-       # It's important that these flags are also passed during the install phase
-       # as well. Make sure of that if you change the lines below. See bug 661308.
-       mydistutilsargs=(
-               build_ext
-               --disable-platform-guessing
-               $(use_enable truetype freetype)
-               $(use_enable jpeg)
-               $(use_enable jpeg2k jpeg2000)
-               $(use_enable lcms)
-               $(use_enable tiff)
-               $(use_enable imagequant)
-               $(use_enable webp)
-               $(use_enable webp webpmux)
-               $(use_enable zlib)
-       )
-}
-
-python_compile() {
-       # Pillow monkeypatches distutils to achieve parallel compilation. This
-       # conflicts with distutils' builtin parallel computation (since py35)
-       # and make builds hang. To avoid that, we set MAX_CONCURRENCY=1 to
-       # disable monkeypatching. Can be removed when/if
-       # https://github.com/python-pillow/Pillow/pull/3272 is merged.
-       MAX_CONCURRENCY=1 distutils-r1_python_compile
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
-
-python_test() {
-       "${PYTHON}" selftest.py --installed || die "selftest failed with ${EPYTHON}"
-       # no:relaxed: pytest-relaxed plugin make our tests fail. deactivate if installed
-       virtx pytest -vx Tests/test_*.py -p no:relaxed
-}
-
-python_install() {
-       python_doheader src/libImaging/*.h
-       distutils-r1_python_install
-}
-
-python_install_all() {
-       use doc && local HTML_DOCS=( docs/_build/html/. )
-       if use examples ; then
-               docinto example
-               dodoc docs/example/*
-               docompress -x /usr/share/doc/${PF}/example
-       fi
-       distutils-r1_python_install_all
-}