net-misc/chrony: clean up configure arguments
authorMike Gilbert <floppym@gentoo.org>
Wed, 25 Sep 2019 06:39:27 +0000 (02:39 -0400)
committerJeroen Roovers <jer@gentoo.org>
Thu, 26 Sep 2019 07:36:04 +0000 (09:36 +0200)
Closes: https://bugs.gentoo.org/695610
Package-Manager: Portage-2.3.75_p7, Repoman-2.3.17_p49
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
net-misc/chrony/chrony-3.5.ebuild
net-misc/chrony/chrony-9999.ebuild

index 21c96f642157788054988107b05eae0bed001d62..c74eea646f90505450c85e512f8078f4e1f5cdea 100644 (file)
@@ -66,34 +66,33 @@ src_configure() {
        fi
 
        # not an autotools generated script
-       local CHRONY_CONFIGURE="
-       ./configure \
-               $(use_enable seccomp scfilter) \
-               $(usex adns '' --disable-asyncdns) \
-               $(usex caps '' --disable-linuxcaps) \
-               $(usex cmdmon '' --disable-cmdmon) \
-               $(usex ipv6 '' --disable-ipv6) \
-               $(usex ntp '' --disable-ntp) \
-               $(usex phc '' --disable-phc) \
-               $(usex pps '' --disable-pps) \
-               $(usex refclock '' --disable-refclock) \
-               $(usex rtc '' --disable-rtc) \
-               ${CHRONY_EDITLINE} \
-               ${EXTRA_ECONF} \
-               --chronysockdir=/run/chrony \
-               --disable-sechash \
-               --docdir=/usr/share/doc/${PF} \
-               --mandir=/usr/share/man \
-               --prefix=/usr \
-               --sysconfdir=/etc/chrony \
+       local myconf=(
+               $(use_enable seccomp scfilter)
+               $(usex adns '' --disable-asyncdns)
+               $(usex caps '' --disable-linuxcaps)
+               $(usex cmdmon '' --disable-cmdmon)
+               $(usex ipv6 '' --disable-ipv6)
+               $(usex ntp '' --disable-ntp)
+               $(usex phc '' --disable-phc)
+               $(usex pps '' --disable-pps)
+               $(usex refclock '' --disable-refclock)
+               $(usex rtc '' --disable-rtc)
+               ${CHRONY_EDITLINE}
+               ${EXTRA_ECONF}
+               --chronysockdir="${EPREFIX}/run/chrony"
+               --disable-sechash
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --mandir="${EPREFIX}/usr/share/man"
+               --prefix="${EPREFIX}/usr"
+               --sysconfdir="${EPREFIX}/etc/chrony"
                --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
-               --without-nss \
+               --without-nss
                --without-tomcrypt
-       "
+       )
 
        # print the ./configure call to aid in future debugging
-       einfo ${CHRONY_CONFIGURE}
-       bash ${CHRONY_CONFIGURE} || die
+       echo bash ./configure "${myconf[@]}" >&2
+       bash ./configure "${myconf[@]}" || die
 }
 
 src_compile() {
index a9bf2fae278249f85add6c66a441b5c996548fca..53dd5de5b8a05fd355191626ccb329025f92cf6b 100644 (file)
@@ -64,34 +64,33 @@ src_configure() {
        fi
 
        # not an autotools generated script
-       local CHRONY_CONFIGURE="
-       ./configure \
-               $(use_enable seccomp scfilter) \
-               $(usex adns '' --disable-asyncdns) \
-               $(usex caps '' --disable-linuxcaps) \
-               $(usex cmdmon '' --disable-cmdmon) \
-               $(usex ipv6 '' --disable-ipv6) \
-               $(usex ntp '' --disable-ntp) \
-               $(usex phc '' --disable-phc) \
-               $(usex pps '' --disable-pps) \
-               $(usex refclock '' --disable-refclock) \
-               $(usex rtc '' --disable-rtc) \
-               ${CHRONY_EDITLINE} \
-               ${EXTRA_ECONF} \
-               --chronysockdir=/run/chrony \
-               --disable-sechash \
-               --docdir=/usr/share/doc/${PF} \
-               --mandir=/usr/share/man \
-               --prefix=/usr \
-               --sysconfdir=/etc/chrony \
+       local myconf=(
+               $(use_enable seccomp scfilter)
+               $(usex adns '' --disable-asyncdns)
+               $(usex caps '' --disable-linuxcaps)
+               $(usex cmdmon '' --disable-cmdmon)
+               $(usex ipv6 '' --disable-ipv6)
+               $(usex ntp '' --disable-ntp)
+               $(usex phc '' --disable-phc)
+               $(usex pps '' --disable-pps)
+               $(usex refclock '' --disable-refclock)
+               $(usex rtc '' --disable-rtc)
+               ${CHRONY_EDITLINE}
+               ${EXTRA_ECONF}
+               --chronysockdir="${EPREFIX}/run/chrony"
+               --disable-sechash
+               --docdir="${EPREFIX}/usr/share/doc/${PF}"
+               --mandir="${EPREFIX}/usr/share/man"
+               --prefix="${EPREFIX}/usr"
+               --sysconfdir="${EPREFIX}/etc/chrony"
                --with-pidfile="${EPREFIX}/run/chrony/chronyd.pid"
-               --without-nss \
+               --without-nss
                --without-tomcrypt
-       "
+       )
 
        # print the ./configure call to aid in future debugging
-       einfo ${CHRONY_CONFIGURE}
-       bash ${CHRONY_CONFIGURE} || die
+       echo bash ./configure "${myconf[@]}" >&2
+       bash ./configure "${myconf[@]}" || die
 }
 
 src_compile() {