www-servers/gunicorn-19.9.0: py38 support added; relaxed sphinx dep.
authorPiotr Karbowski <slashbeast@gentoo.org>
Mon, 30 Dec 2019 21:53:26 +0000 (22:53 +0100)
committerPiotr Karbowski <slashbeast@gentoo.org>
Mon, 30 Dec 2019 21:54:09 +0000 (22:54 +0100)
The sphinx dependency has been relaxed to not force sphinx to be installed
with the same PYTHON_TARGETS as the gunicorn itself.

No revbump as the end result with USE=doc is the same as it was before.

Signed-off-by: Piotr Karbowski <slashbeast@gentoo.org>
www-servers/gunicorn/gunicorn-19.9.0.ebuild

index c98e3a00bb6f96dec53c0afc5936010ca0feab07..d79648682864c79f6dfa4cc8c293b445ccd61db4 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
-PYTHON_COMPAT=( python2_7 python3_{5,6,7} pypy )
+PYTHON_COMPAT=( python2_7 python3_{5,6,7,8} pypy )
 
 inherit distutils-r1
 
@@ -13,13 +13,12 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 LICENSE="MIT PSF-2 doc? ( BSD )"
 SLOT="0"
 KEYWORDS="amd64 ~arm ~arm64 x86"
-IUSE="doc test"
+IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/setproctitle[${PYTHON_USEDEP}]"
 DEPEND="
        dev-python/setuptools[${PYTHON_USEDEP}]
-       doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
        test? (
                dev-python/mock[${PYTHON_USEDEP}]
                dev-python/pytest[${PYTHON_USEDEP}]
@@ -29,22 +28,14 @@ DEPEND="
 
 DOCS="README.rst"
 
-python_prepare_all() {
-       sed -ie "s/..\/bin/\/usr\/bin\//" docs/Makefile || die
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
-       use doc && emake -C docs html
-}
+distutils_enable_sphinx 'docs/source' --no-autodoc
 
 python_test() {
        py.test -v || die "Testing failed with ${EPYTHON}"
 }
 
 python_install_all() {
-       use doc && local HTML_DOCS=( docs/build/html/. )
+       use doc && local HTML_DOCS=( docs/source/_build/html/. )
 
        distutils-r1_python_install_all
 }