games-strategy/colobot-data: drop live ebuild
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 11 May 2019 11:50:04 +0000 (12:50 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 11 May 2019 11:50:24 +0000 (12:50 +0100)
Live ebuild refers to '-latest' file upstream. '-latest' file
does not match checksum mirrored by gentoo's system. Better
track data assets as proper release ebuilds.

Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
games-strategy/colobot-data/Manifest
games-strategy/colobot-data/colobot-data-9999.ebuild [deleted file]

index 0ef50534c66eb2411bd626b18a78d753ba3e5c35..1d2b72544ea4c817abbf274df819604fc95a4e92 100644 (file)
@@ -1,5 +1,3 @@
 DIST colobot-data-0.1.11-music-flac.tar.gz 298829480 BLAKE2B 2a041df82b295433257dd0358b6f83d585cae086a7c1f7e891964a4ffca2e1ca71bb68f7f01160c8dddaeb3b553fcc0082ab746177836d8b9494376a9a9b4451 SHA512 0ab613ea8ca59771b5d93b9c8d96ad88a0fe27f6171be0cb1d6d2eb60b820fdcad83f8fdc5d2f968e8091a6f3e727eb202c4dd09f86afb3eb2e325756eb40873
 DIST colobot-data-0.1.11-music-ogg.tar.gz 55596353 BLAKE2B 63be871fc2000c1cb041658b7395d5175cefc24c81661b366396965951efdadf1cf064211f3f543c4a4b1b7da5bd91db5e397844f1e8771318302c9d80788eb4 SHA512 486d084adc1b28a9fe36c530d261e48a89553c822989f493b0a92dabb9c3435953bda6fe98fcdabc72c6969b5e9be4ff9f3803066f6115fc7740c3de5d183764
 DIST colobot-data-0.1.11.zip 55796087 BLAKE2B 2a1a6fc57bb61423360f89c8bac597754cab872b3154f9b3464bef88555e4dcb9e0296a4b6f85271ef95e71c69d1c31737c8ae3b932a0b64dc8d7cfa8393481b SHA512 2024759af47b4c406325e1d72d119391712ec9d53b4059f3e942e0bd2b3881fdbc9613f79510b9b012cdbc76bebd8a008531da4f94be5d6107887bbcb330417f
-DIST colobot-data-9999-music-flac.tar.gz 298829480 BLAKE2B 2a041df82b295433257dd0358b6f83d585cae086a7c1f7e891964a4ffca2e1ca71bb68f7f01160c8dddaeb3b553fcc0082ab746177836d8b9494376a9a9b4451 SHA512 0ab613ea8ca59771b5d93b9c8d96ad88a0fe27f6171be0cb1d6d2eb60b820fdcad83f8fdc5d2f968e8091a6f3e727eb202c4dd09f86afb3eb2e325756eb40873
-DIST colobot-data-9999-music-ogg.tar.gz 3686106 BLAKE2B c1565dbcf1aab0e29014623c924ade2ac1b5da9ae9d9231afe3299dfedab0678c3d222e58665fe3ac60291972b7c2d763437246d7816ca7c16e69766a52e9490 SHA512 2ec22944857ccc5276b93d0da4684bfd9d2a80ac712e3396cb01ccbf21a582c22d525e8af9d12828e224ee948173bffb5e31f664cc9333b79b6f3062dd2466ac
diff --git a/games-strategy/colobot-data/colobot-data-9999.ebuild b/games-strategy/colobot-data/colobot-data-9999.ebuild
deleted file mode 100644 (file)
index 63f52ef..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-EGIT_REPO_URI="https://github.com/colobot/colobot-data"
-
-inherit git-r3 cmake-utils
-
-DESCRIPTION="Data package for colobot (Colonize with Bots)"
-HOMEPAGE="https://colobot.info/"
-SRC_URI="
-       music_ogg? ( https://colobot.info/files/music/colobot-music_ogg_latest.tar.gz -> ${P}-music-ogg.tar.gz )
-       music_flac_convert? ( https://colobot.info/files/music/colobot-music_flac_latest.tar.gz -> ${P}-music-flac.tar.gz )"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="+music music_flac_convert +music_ogg"
-REQUIRED_USE="
-       music? ( ^^ ( music_flac_convert music_ogg ) )
-       music_flac_convert? ( music )
-       music_ogg? ( music )"
-
-DEPEND="
-       app-arch/unzip
-       music_flac_convert? ( media-sound/vorbis-tools )"
-
-src_unpack() {
-       git-r3_src_unpack
-
-       if use music; then
-               tar xf "${DISTDIR}/${P}"-music-*.tar.gz -C "${S}/music" || die "Failed to unpack music"
-       fi
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       if use music; then
-               sed -i -e '/find_program(WGET wget)/d' -e '/if(NOT WGET)/,+2 d' music/CMakeLists.txt || die
-       fi
-}
-
-src_configure() {
-       local mycmakeargs=(
-               -DMUSIC=$(usex music)
-               -DMUSIC_FLAC=$(usex music_flac_convert)
-               -DMUSIC_QUALITY="${COLOBOT_DATA_MUSIC_QUALITY:-4}"
-       )
-       cmake-utils_src_configure
-}