gnome-extra/gnome-characters: bump to 3.32.1
authorMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 11:57:32 +0000 (14:57 +0300)
committerMart Raudsepp <leio@gentoo.org>
Sun, 13 Oct 2019 12:06:02 +0000 (15:06 +0300)
Package-Manager: Portage-2.3.69, Repoman-2.3.12
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
gnome-extra/gnome-characters/Manifest
gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild [new file with mode: 0644]

index caf164506dec29b832e0e3750294837af8f441f4..cf17ee11f221d9fb002b34644eb7131d4a5312c5 100644 (file)
@@ -1 +1,2 @@
 DIST gnome-characters-3.30.0.tar.xz 974068 BLAKE2B 294b401e410e4383120deaa4ef3adad485c27e59879ff412d9eb282678f07faba6fb5a93e01c0aebaac7dbac7abd5c19876a0b84403ad92ffc24211daec961bd SHA512 390536e0e5891497c5bd2374c70085beb5bc7c730f51d889e4147895f24999c5c3e9a0bc466a3d4c5652922f1cd7ce1f8f1a98e61007df59d682c230bc99acd2
+DIST gnome-characters-3.32.1.tar.xz 186516 BLAKE2B f6c6b95fbaab9f2e2e6454256bff87b243629927b1806161de2294a8b497cc1f601da747252f14dc8c232bbbaa581140b513a4db0c9993ee05295a82e294787b SHA512 d2c18b136da6ab35938de4adf74ee6c3841f5f8e46f3b1ed2bbb8f9d0e953bba1dc43e105ae2aafc880f3cba37b75a55d274e6776d2bc17a5e30364f5d625537
diff --git a/gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild b/gnome-extra/gnome-characters/gnome-characters-3.32.1.ebuild
new file mode 100644 (file)
index 0000000..c230871
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_5,3_6} )
+
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Unicode character map viewer and library"
+HOMEPAGE="https://wiki.gnome.org/Design/Apps/CharacterMap"
+
+LICENSE="GPL-2+ BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+RDEPEND="
+       >=dev-libs/gjs-1.50
+       >=dev-libs/glib-2.32:2
+       >=dev-libs/gobject-introspection-1.35.9:=
+       >=dev-libs/libunistring-0.9.5
+       >=x11-libs/gtk+-3.20:3[introspection]
+       x11-libs/gdk-pixbuf:2
+       >=x11-libs/pango-1.36[introspection]
+"
+DEPEND="${RDEPEND}
+       dev-libs/libxml2:2
+       dev-util/glib-utils
+       >=sys-devel/gettext-0.19.8
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       xdg_pkg_postinst
+       gnome2_schemas_update
+}
+
+pkg_postinst() {
+       xdg_pkg_postrm
+       gnome2_schemas_update
+}