dev-libs/libdynd: version bump
authorSébastien Fabbro <bicatali@gentoo.org>
Sun, 8 Jan 2017 06:47:28 +0000 (06:47 +0000)
committerSébastien Fabbro <bicatali@gentoo.org>
Tue, 10 Jan 2017 05:26:40 +0000 (05:26 +0000)
Cleaned old buggy versions.

Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-libs/libdynd/Manifest
dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch [deleted file]
dev-libs/libdynd/libdynd-0.6.5.ebuild [deleted file]
dev-libs/libdynd/libdynd-0.6.6.ebuild [deleted file]
dev-libs/libdynd/libdynd-0.7.2.ebuild [new file with mode: 0644]
dev-libs/libdynd/metadata.xml

index 695bfcc8db3d88ef34ace0b6bc191bf74ef1429d..b6d331fd255cb34e713cbbe599ff28f6626348c8 100644 (file)
@@ -1,2 +1 @@
-DIST libdynd-0.6.5.tar.gz 1238404 SHA256 bf2e5c88995f0da880c3d7552c2541138c0f07eb6555f0ee10c77d805f8b3f65 SHA512 ebf64b94b38300e4e471f975a51e4b014879937e855af5d72a3f759af4445fa9024e42962ab1284ebe7b2ae2ddf51ea418d106c9894e1841f0984622afbef115 WHIRLPOOL 9222608edd8382ec2f8dbd7dd85eb0392d79a527d94f959f011430b2d15bbf405ccf06954e20679e26e93cd7c356b70f7490280e097cfc833ac015612a5cfe77
-DIST libdynd-0.6.6.tar.gz 1261349 SHA256 0e05eedd6b230f122a6c92fb6306be3017b0a5c460af5eace0074640455ef17e SHA512 efeb52a5b5dd3154ca293f388d5b967ff983450253435572b919f7c4a1445ad3cb416def4c736f908fdb3b06cddebae881a58420e528f1ca145973a997af7a28 WHIRLPOOL 8479f280a883f07382280b8fb94a3c21e8ef9975b67fe31bed83a40b9ad7e5b939c48ac76c638492faeb91143e449471c0d316078066c4d9752e4b238f3cd822
+DIST libdynd-0.7.2.tar.gz 1342364 SHA256 be764817ca6e72dd65a32698b0a7f64df111b732c3230b5b8a8bfc72a3b0c750 SHA512 134195ba5839e05af07dd9ad0b8e749a83345511acd2a22a029a4d9a2c0fc77a8a1f36722bce20653d28189b7883afe7feb651c7d32ff921ef257a8a9aa4bd7f WHIRLPOOL 4969f747f3b0cf1a46681aaae78d470762aa6321aea8f0cf95ef55ee061a247fb24c6d8667adff5ebf6bfdf99408dfdcf8e5cd4ed37c00fb856a5eae8127c615
diff --git a/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch b/dev-libs/libdynd/files/libdynd-0.6.0-dont-install-test.patch
deleted file mode 100644 (file)
index 9659372..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
---- tests/CMakeLists.txt.orig  2014-02-10 14:25:18.041841087 -0800
-+++ tests/CMakeLists.txt       2014-02-10 14:25:40.224975614 -0800
-@@ -105,12 +105,6 @@
-         )
- endif()
--# If installation is requested, install the program
--if (DYND_INSTALL_LIB)
--    install(TARGETS test_libdynd
--        RUNTIME DESTINATION bin)
--endif()
--
- # Compile-time tests: test code that is supposed to produce compile errors
- # I couldn't find a properly specified way to do this, so hacked together
- # this function.
diff --git a/dev-libs/libdynd/libdynd-0.6.5.ebuild b/dev-libs/libdynd/libdynd-0.6.5.ebuild
deleted file mode 100644 (file)
index 49451de..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit cmake-utils multilib cuda
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=2e140844d4a21c436ca0fc46996bf8606ffc21d5
-
-DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
-HOMEPAGE="https://github.com/ContinuumIO/libdynd"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw test"
-
-RDEPEND="
-       dev-libs/c-blosc:0=
-       cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
-       fftw? ( sci-libs/fftw:3.0 )
-       "
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-       # each relase comes with a different set...
-       # remove forced strong flags
-       sed -i \
-               -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
-               -e "s|@DYND_VERSION@|${PV}|" \
-               -e 's|-fomit-frame-pointer||' \
-               -e 's|-Werror||g' \
-               CMakeLists.txt || die
-}
-
-src_configure() {
-       sed -i \
-               -e '/add_subdirectory(examples)/d' \
-               CMakeLists.txt || die
-       local mycmakeargs=(
-               -DDYND_SHARED_LIB=ON
-               -DDYND_INSTALL_LIB=ON
-               $(cmake-utils_use cuda DYND_CUDA)
-               $(cmake-utils_use test DYND_BUILD_TESTS)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       cd "${BUILD_DIR}" || die
-       ./tests/test_libdynd || die
-}
-
-src_install() {
-       cmake-utils_src_install
-       use doc && dodoc documents/*
-}
diff --git a/dev-libs/libdynd/libdynd-0.6.6.ebuild b/dev-libs/libdynd/libdynd-0.6.6.ebuild
deleted file mode 100644 (file)
index 5962297..0000000
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI=5
-
-inherit cmake-utils multilib cuda
-
-# change each release, to avoid git in tree dependency
-DYND_GIT_SHA1=09fb7e5eccadbe1ec49ff4b05fec724939331e6d
-
-DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
-HOMEPAGE="https://github.com/ContinuumIO/libdynd"
-SRC_URI="https://github.com/ContinuumIO/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0/${PV}"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="cuda doc fftw test"
-
-RDEPEND="
-       dev-libs/c-blosc:0=
-       cuda? ( x11-drivers/nvidia-drivers dev-util/nvidia-cuda-toolkit )
-       fftw? ( sci-libs/fftw:3.0 )
-       "
-DEPEND="${RDEPEND}"
-
-DOCS=( README.md )
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.6.0-dont-install-test.patch
-)
-
-src_prepare() {
-       cmake-utils_src_prepare
-       # each relase comes with a different set...
-       # remove forced strong flags
-       sed -i \
-               -e "s|@DYND_GIT_SHA1@|${DYND_GIT_SHA1}|" \
-               -e "s|@DYND_VERSION@|${PV}|" \
-               -e 's|-fomit-frame-pointer||' \
-               -e 's|-Werror||g' \
-               CMakeLists.txt || die
-}
-
-src_configure() {
-       sed -i \
-               -e '/add_subdirectory(examples)/d' \
-               CMakeLists.txt || die
-       local mycmakeargs=(
-               -DDYND_SHARED_LIB=ON
-               -DDYND_INSTALL_LIB=ON
-               $(cmake-utils_use cuda DYND_CUDA)
-               $(cmake-utils_use test DYND_BUILD_TESTS)
-       )
-       cmake-utils_src_configure
-}
-
-src_test() {
-       cd "${BUILD_DIR}" || die
-       ./tests/test_libdynd || die
-}
-
-src_install() {
-       cmake-utils_src_install
-       use doc && dodoc documents/*
-}
diff --git a/dev-libs/libdynd/libdynd-0.7.2.ebuild b/dev-libs/libdynd/libdynd-0.7.2.ebuild
new file mode 100644 (file)
index 0000000..37b608c
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils cuda
+
+DESCRIPTION="C++ dynamic multi-dimensionnal array library with Python exposure"
+HOMEPAGE="http://libdynd.org"
+SRC_URI="https://github.com/libdynd/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="cuda doc fftw mkl test"
+
+RDEPEND="
+       dev-libs/c-blosc:0=
+       cuda? ( dev-util/nvidia-cuda-toolkit )
+       fftw? ( sci-libs/fftw:3.0 )
+"
+DEPEND="${RDEPEND}
+       doc? ( app-doc/doxygen[dot] )
+"
+
+DOCS=( README.md )
+
+src_prepare() {
+       #use cuda && cuda_src_prepare
+       cmake-utils_src_prepare
+       cmake_comment_add_subdirectory examples
+       # fix forced cxxflags and doc installation directory
+       sed -e 's|-O3 -fomit-frame-pointer||' \
+               -e 's|-Werror||g' \
+               -e "s|docs DESTINATION docs|docs/html DESTINATION share/doc/${PF}|" \
+               -i CMakeLists.txt || die
+       # don't install test exec
+       sed -e 's|install(TARGETS test_libdynd||' \
+               -e 's|RUNTIME DESTINATION bin)||' \
+               -i tests/CMakeLists.txt || die
+       # not tested
+       if use mkl; then
+               sed -e "s|/opt/intel/.*|$(ls -1d ${EPREFIX}/opt/intel/compilers*)|" \
+                       -i tests/CMakeLists.txt || die
+       fi
+}
+
+src_configure() {
+       local mycmakeargs=(
+               -DDYND_INSTALL_LIB=ON
+               -DDYND_SHARED_LIB=ON
+               -DDYND_BUILD_BENCHMARKS=OFF
+               -DDYND_BUILD_DOCS="$(usex doc)"
+               -DDYND_BUILD_PLUGIN="$(usex mkl)"
+               -DDYND_BUILD_TESTS="$(usex test)"
+               -DDYND_CUDA="$(usex cuda)"
+               -DDYND_FFTW="$(usex fftw)"
+               -DFFTW_PATH="${EPREFIX}/usr"
+       )
+       cmake-utils_src_configure
+}
+
+src_test() {
+       cd "${BUILD_DIR}" || die
+       ./tests/test_libdynd || die
+}
index 902c488513b335ec396cd43e3b03dd82c44ea54f..0b3978ba39fecec0f46cd772ce4d027f0c784a3a 100644 (file)
@@ -6,19 +6,20 @@
     <name>Gentoo Science Project</name>
   </maintainer>
   <longdescription lang="en">
-  LibDyND, a component of the Blaze project, is a C++ library for
-  dynamic, multidimensional arrays. It is inspired by NumPy, the
-  Python array programming library at the core of the scientific
-  Python stack, but tries to address a number of obstacles encountered
-  by some of its users. Examples of this are support for
-  variable-sized string and ragged array types. The library is in a
-  preview development state, and can be thought of as a sandbox where
-  features are being tried and tweaked to gain experience with them.
-</longdescription>
+    LibDyND, a component of the Blaze project, is a C++ library for
+    dynamic, multidimensional arrays. It is inspired by NumPy, the
+    Python array programming library at the core of the scientific
+    Python stack, but tries to address a number of obstacles encountered
+    by some of its users. Examples of this are support for
+    variable-sized string and ragged array types. The library is in a
+    preview development state, and can be thought of as a sandbox where
+    features are being tried and tweaked to gain experience with them.
+  </longdescription>
   <use>
     <flag name="cuda">Enable NVIDIA CUDA toolkit support</flag>
+    <flag name="mkl">Enable a plugin for Intel Math Kernel Library <pkg>sci-libs/mkl</pkg></flag>
   </use>
   <upstream>
-    <remote-id type="github">ContinuumIO/libdynd</remote-id>
+    <remote-id type="github">libdynd/libdynd</remote-id>
   </upstream>
 </pkgmetadata>