sys-libs/librtas: EAPI=7 and other minor fixes
authorJeroen Roovers <jer@gentoo.org>
Tue, 12 May 2020 09:59:56 +0000 (11:59 +0200)
committerJeroen Roovers <jer@gentoo.org>
Tue, 12 May 2020 10:01:27 +0000 (12:01 +0200)
- EAPI=7
- Do not install static libraries by default
- Fix docdir
- Prune libtool files

Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
sys-libs/librtas/librtas-2.0.2-r1.ebuild [new file with mode: 0644]

diff --git a/sys-libs/librtas/librtas-2.0.2-r1.ebuild b/sys-libs/librtas/librtas-2.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..d366c24
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="A set of libraries for userspace access to RTAS on the PowerPC platform(s)"
+HOMEPAGE="https://github.com/ibm-power-utilities/librtas"
+SRC_URI="https://github.com/ibm-power-utilities/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~ppc ~ppc64"
+IUSE="static-libs"
+
+DOCS="README"
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_configure() {
+       econf $(use_enable static-libs static)
+}
+
+src_install() {
+       emake DESTDIR="${D}" install docdir=/usr/share/doc/${PF}
+       find "${D}" -name '*.la' -delete || die
+}