Modified i810 to be restart instead of start, closes bug#159399, thanks for Stefan...
authorAlon Bar-Lev <alonbl@gentoo.org>
Sat, 30 Dec 2006 10:32:32 +0000 (10:32 +0000)
committerAlon Bar-Lev <alonbl@gentoo.org>
Sat, 30 Dec 2006 10:32:32 +0000 (10:32 +0000)
Package-Manager: portage-2.1.1-r2

sys-power/hibernate-script/ChangeLog
sys-power/hibernate-script/files/digest-hibernate-script-1.94-r2 [new file with mode: 0644]
sys-power/hibernate-script/hibernate-script-1.94-r2.ebuild [new file with mode: 0644]

index e941ff659e84b01715d707706620537a63bc459e..4e5ad77332fb933ea87313829623d483523b6083 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for sys-power/hibernate-script
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.42 2006/12/21 21:03:05 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/ChangeLog,v 1.43 2006/12/30 10:32:32 alonbl Exp $
+
+*hibernate-script-1.94-r2 (30 Dec 2006)
+
+  30 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org>
+  -hibernate-script-1.94-r1.ebuild, +hibernate-script-1.94-r2.ebuild:
+  Modified i810 to be restart instead of start, closes bug#159399, thanks for
+  Stefan Becker
 
 *hibernate-script-1.94-r1 (21 Dec 2006)
 
diff --git a/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r2 b/sys-power/hibernate-script/files/digest-hibernate-script-1.94-r2
new file mode 100644 (file)
index 0000000..68cf6d3
--- /dev/null
@@ -0,0 +1,6 @@
+MD5 8e3cbd0938b73507fecaf0da4b77d4ce hibernate-script-1.94-patches-3.tar.bz2 3229
+RMD160 9b41f5adff15b5cfb988afb5b7f1e2c462f19c5b hibernate-script-1.94-patches-3.tar.bz2 3229
+SHA256 08b991b9fbe2709acab9240d23107c82d99fc1b00ea204c411140e841c8c391e hibernate-script-1.94-patches-3.tar.bz2 3229
+MD5 f8826d4c96e320902382f29c91694c04 hibernate-script-1.94.tar.gz 72928
+RMD160 31d105c08bf183e3bc770543e0ae01678798859b hibernate-script-1.94.tar.gz 72928
+SHA256 57ad0de0cce263c76303a5c7116550f19aaec540c6743e0b5bcd5d0cb68d2fe2 hibernate-script-1.94.tar.gz 72928
diff --git a/sys-power/hibernate-script/hibernate-script-1.94-r2.ebuild b/sys-power/hibernate-script/hibernate-script-1.94-r2.ebuild
new file mode 100644 (file)
index 0000000..dbf1dcc
--- /dev/null
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-power/hibernate-script/hibernate-script-1.94-r2.ebuild,v 1.1 2006/12/30 10:32:32 alonbl Exp $
+
+inherit eutils
+
+PATCH_VERSION="3"
+
+DESCRIPTION="Hibernate script supporting multiple suspend methods"
+HOMEPAGE="http://www.suspend2.net/"
+SRC_URI="http://www.suspend2.net/downloads/all/${P}.tar.gz
+       mirror://gentoo/${P}-patches-${PATCH_VERSION}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+IUSE="logrotate vim"
+
+DEPEND="sys-apps/sed"
+RDEPEND="logrotate? ( app-admin/logrotate )"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       rm -f "${S}"/scriptlets.d/swsusp2_15
+       epatch "${WORKDIR}"/patches/*.patch
+}
+
+src_install() {
+       BASE_DIR="${D}" PREFIX=/usr MAN_DIR="${D}"/usr/share/man \
+               "${S}"/install.sh || die "Install failed"
+
+       # hibernate-ram will default to using ram.conf
+       dosym /usr/sbin/hibernate /usr/sbin/hibernate-ram
+
+       newinitd "${S}"/init.d/hibernate-cleanup.sh hibernate-cleanup
+
+       # other ebuilds can install scriplets to this dir
+       keepdir /etc/hibernate/scriptlets.d/
+
+       if use vim; then
+               insinto /usr/share/vim/vimfiles
+               doins hibernate.vim
+       fi
+
+       dodoc CHANGELOG README SCRIPTLET-API hibernate.vim
+
+       if use logrotate; then
+               insinto /etc/logrotate.d
+               newins "${S}"/logrotate.d-hibernate-script hibernate-script
+       fi
+}
+
+pkg_postinst() {
+       elog
+       elog "You should run the following command to invalidate"
+       elog "suspend images on a clean boot."
+       elog
+       elog "  # rc-update add hibernate-cleanup boot"
+       elog
+       elog "See /usr/share/doc/${PF}/README.gz for further details."
+       elog
+       elog "Please note that you will need to manually emerge any utilities"
+       elog "(radeontool, vbetool, ...) enabled in the configuration files,"
+       elog "should you wish to use them."
+       elog
+       elog "Starting with hibernate-script-1.90 the configuration files have"
+       elog "been reordered and split into method specific files. Make sure you"
+       elog "update your /etc/hibernate/ configuration files accordingly."
+       elog
+}