dev-util/scons: fix CC, CXX, C*FLAGS, LDFLAGS tests
authorband-a-prend <torokhov-s-a@yandex.ru>
Fri, 7 Jun 2019 21:45:13 +0000 (00:45 +0300)
committerMichał Górny <mgorny@gentoo.org>
Sat, 15 Jun 2019 14:19:18 +0000 (16:19 +0200)
Unset the AR AS ASFLAGS, CC, CXX, CFLAGS, CXXFLAGS, CPPFLAGS, LDFLAGS flags within python_test() phase
to ignore the "*-respect-cc-etc-r1.patch" within test env.

It repairs the failures of the tests that are associated with this flags.
Failures were caused by parsing error of passed values.

Signed-off-by: Sergey Torokhov <torokhov_s_a@mail.ru>
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/scons/scons-3.0.5-r1.ebuild

index e7f2ac66479c13e4f27b04b35b3d6c7c6ea66f64..d38461f93b0d179064e4d63cae14d1d726353a92 100644 (file)
@@ -64,6 +64,8 @@ src_prepare() {
 python_test() {
        # set variable from escons() of scons-util.eclass to make env-passthrough patch work within test env
        local -x GENTOO_SCONS_ENV_PASSTHROUGH=1
+       # unset some env variables to pass appropriate tests
+       unset AR AS ASFLAGS CC CXX CFLAGS CXXFLAGS CPPFLAGS LDFLAGS
        cd "${WORKDIR}/${P}" || die
        "${EPYTHON}" runtest.py -a --passed \
                -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \