x11-drivers/xf86-video-amdgpu: Add patch for GCC-10
authorMatt Turner <mattst88@gentoo.org>
Fri, 1 May 2020 18:49:01 +0000 (11:49 -0700)
committerMatt Turner <mattst88@gentoo.org>
Fri, 1 May 2020 18:54:34 +0000 (11:54 -0700)
Closes: https://bugs.gentoo.org/719950
Signed-off-by: Matt Turner <mattst88@gentoo.org>
x11-drivers/xf86-video-amdgpu/files/xf86-video-amdgpu-19.1.0-Fix-link-failure-with-gcc-10.patch [new file with mode: 0644]
x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-19.1.0.ebuild

diff --git a/x11-drivers/xf86-video-amdgpu/files/xf86-video-amdgpu-19.1.0-Fix-link-failure-with-gcc-10.patch b/x11-drivers/xf86-video-amdgpu/files/xf86-video-amdgpu-19.1.0-Fix-link-failure-with-gcc-10.patch
new file mode 100644 (file)
index 0000000..cab3d1b
--- /dev/null
@@ -0,0 +1,28 @@
+From edcbe5f52ddfceee3d66d69bbcebbceac06b6d0d Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 4 Feb 2020 16:38:06 -0500
+Subject: [PATCH] Fix link failure with gcc 10
+
+Without the 'extern' this looks like a definition not just a
+declaration, in every file that includes the header. gcc 10 is stricter
+about this kind of multiple definition.
+---
+ src/drmmode_display.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/drmmode_display.h b/src/drmmode_display.h
+index 803ac3c..9c0f25a 100644
+--- a/src/drmmode_display.h
++++ b/src/drmmode_display.h
+@@ -289,7 +289,7 @@ Bool drmmode_wait_vblank(xf86CrtcPtr crtc, drmVBlankSeqType type,
+                        uint64_t *ust, uint32_t *result_seq);
+-miPointerSpriteFuncRec drmmode_sprite_funcs;
++extern miPointerSpriteFuncRec drmmode_sprite_funcs;
+ #endif
+-- 
+2.26.2
+
index d1d64a0c5d9989360eb15e924c3d96751158fdd2..1c98f5bc557738f545689c5ea6139134de11b999 100644 (file)
@@ -20,6 +20,10 @@ RDEPEND=">=x11-libs/libdrm-2.4.89[video_cards_amdgpu]
        udev? ( virtual/libudev:= )"
 DEPEND="${RDEPEND}"
 
+PATCHES=(
+       "${FILESDIR}"/${P}-Fix-link-failure-with-gcc-10.patch
+)
+
 pkg_setup() {
        XORG_CONFIGURE_OPTIONS=(
                --enable-glamor