dev-python/zc-buildout: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:16:34 +0000 (17:16 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:16:34 +0000 (17:16 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/zc-buildout/zc-buildout-2.5.3-r1.ebuild

index fdff18c3a853336995a28e32e20c35229f521159..7e50c6d015f2654defacded3c628a44f22169d9b 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=5
-PYTHON_COMPAT=( python{2_7,3_5,3_6} pypy pypy3 )
+PYTHON_COMPAT=( python3_{5,6} pypy3 )
 
 inherit distutils-r1
 
@@ -17,7 +17,8 @@ LICENSE="ZPL"
 SLOT="0"
 KEYWORDS="~amd64 ~x86"
 IUSE="test"
-RESTRICT="!test? ( test )"
+# Tests are broken
+RESTRICT="test"
 
 RDEPEND=">=dev-python/setuptools-3.3[${PYTHON_USEDEP}]"
 DEPEND="${RDEPEND}
@@ -34,11 +35,6 @@ python_prepare_all() {
 }
 
 python_test() {
-       if python_is_python3; then
-               ewarn "Tests are broken for ${EPYTHON}, skipping"
-               continue
-       fi
-
        distutils_install_for_testing
        "${PYTHON}" src/zc/buildout/tests.py || die "Tests fail with ${EPYTHON}"
 }