dev-python/httpretty: Add missing test deps
authorMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 09:23:33 +0000 (11:23 +0200)
committerMichał Górny <mgorny@gentoo.org>
Mon, 27 Apr 2020 09:30:20 +0000 (11:30 +0200)
Closes: https://bugs.gentoo.org/719766
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/httpretty/httpretty-1.0.2-r1.ebuild [new file with mode: 0644]

diff --git a/dev-python/httpretty/httpretty-1.0.2-r1.ebuild b/dev-python/httpretty/httpretty-1.0.2-r1.ebuild
new file mode 100644 (file)
index 0000000..eb33b6f
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="HTTP client mock for Python"
+HOMEPAGE="https://github.com/gabrielfalcao/httpretty"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       dev-python/urllib3[${PYTHON_USEDEP}]"
+# redis skipped as it requires a redis server running
+DEPEND="
+       test? (
+               dev-python/eventlet[${PYTHON_USEDEP}]
+               dev-python/freezegun[${PYTHON_USEDEP}]
+               dev-python/httplib2[${PYTHON_USEDEP}]
+               >=dev-python/nose-1.2[${PYTHON_USEDEP}]
+               dev-python/pyopenssl[${PYTHON_USEDEP}]
+               >=dev-python/requests-1.1[${PYTHON_USEDEP}]
+               dev-python/sure[${PYTHON_USEDEP}]
+               >=www-servers/tornado-2.2[${PYTHON_USEDEP}]
+)"
+
+python_prepare_all() {
+       # remove useless deps
+       sed -i -e '/randomly/d' -e '/rednose/d' setup.cfg || die
+       # tests requiring network access
+       rm tests/functional/test_passthrough.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_test() {
+       nosetests -v tests || die "Tests fail with ${EPYTHON}"
+}